Can't flash photon

I purchased a photon over a year ago but only just started using it today. I set it up, and connected it to my wifi through my phone. I was able to set up the device in the IDE, when I push the signal button it blinks accordingly.

When I try to flash the device it times out and tells me it’s unsuccessful. I set up the the particle cli and firmware utility to update the device. I put it in the yellow blinking mode and have tried the update command, the doctor command and about everything else I could find but I get nothing but “Error - No DFU device found.”

I tried connecting to the device over serial (in listening mode) but it seems to not exist. An ls /dev returns nothing.

Feels like this thing is bricked yet there is still some connectivity to the cloud because the signaling works. What am I doing wrong?

What OS are you using CLI on?

  • For Windows you need DFU drivers (pre Win10 even serial drivers were required)

How did you install CLI?

  • For Windows there is an installer that also brings the extras needed

What does the device do when you try flashing it via Web IDE?

1 Like

I’m on OSX 10.9.5. Installed the cli via npm (node 6, ran update beforehand).

When I try to flash it with the web ide it says:
Flashing code…
The request seems to take longer than usual. Please be patient…
Flash Successful. Your device is being updated…

The device never changes from the breathing blue light through this whole process.

One other note, when I put it into DFU mode the light isn’t solid yellow, there also seems to be a tiny bit of red to it. I’m wondering if this is what the “bad server key” error mode is. I tried the particle doctor keys command but since there doesn’t seem to be a serial connection to the board it told me it couldn’t find any devices in DFU mode.

RGB stands for red, green & blue and yellow is made up from red + green :wink: