Photon: dfu-util - No DFU Device found

Hiii,
First timer here… So please excuse me if I haven’t been able to explain my problem clearly.

I’m trying to flash my Photon locally, but the dfu-util is not able to detect the photon in DFU mode no matter what. I’ve tried two machines (Macbook Pro as well as Windows 8.1 laptop), every USB port available on both the machines and 6 different USB cables. The Photon is flashing yellow which indicates that the Photon did enter DFU mode. On Windows machine I keep getting error USB Device not recognised. On the Mac, while the Photon is in DFU Mode, the dfu-util -l command gives the following output

Found Runtime: [05ac:8286] ver=0151, devnum=7, cfg=1, intf=3, alt=0, name=“UNKNOWN”, serial=“UNKNOWN”

But as soon as I run any command on Particle CLI to flash the Photon, I get the following

!!! I was unable to detect any devices in DFU mode…

Your device will blink yellow when in DFU mode.
If your device is not blinking yellow, please:

  1. Press and hold both the RESET/RST and MODE/SETUP buttons simultaneously.
  2. Release only the RESET/RST button while continuing to hold the MODE/SETUP button.
  3. Release the MODE/SETUP button once the device begins to blink yellow.

Error writing firmware…No DFU device found

Further in listening mode (i.e flashing blue), when I run the command particle serial list, it gives

No devices available via serial

Any ideas what might be wrong ??? Did I finally manage to break my Photon???

Thanks in advance…

Did you try both USB port on the Macbook?

Thanks for the quick reply.
Yes I did try both the ports… On the Windows machine I had 4 USB ports and I tried on all of them as well…

Weird. Can you place the Photon in Listening mode (blinking blue) and test particle serial identify?

Did you install the relevant drivers?

Hi @kennethlimcp, particle serial identify gives…

! serial: No devices available via serial

Hi @Moors7, Yes the relevant drivers have been installed… I have two Photons and the other one works just fine…

So my take is maybe the photon has some issues… Do you have the USB cable from Particle?

I don’t, I didn’t but the kit … Just bought the board…

Hi!
Dont know if you need help anymore… but have you already installed the usb-driver via zadig_2.2.exe ?

Greetings
Alex

Did this issue get solved? I have the same issue. MacBook, tried both USB ports, device blinking yellow, etc. I’m going this because of “network errors when attempting to connect to cloud” either when using Tinker or command line utilities.