Can't flash Photon but can signal

I can signal (from web, so I know it is connected) my proton, but whenever I flash I get “timeout”.

Flash from web?, d/l firmware and flash local

From the IDE, I tried flashing but it keeps saying “time out”.

use the Particle CLI

Should the web IDE work, or is that not supported?
Or once I flash locally, it should start working from the web again?

It definitely should!
“Just use the CLI” isn’t, and shouldn’t be, the answer (though it does work).

Could you give Safe Mode a try?

I don’t believe I used the word “just”…anyway, how about the questions… has it ever flashed before? does it work currently?, and are just updating your code? does your code have the photon going to sleep at all? That would cause it to timeout too.

1 Like

Didn’t mean you said it, was just asking.

The protons I had for a bit, I don’t know if I ever got around to using them, I got them at launch. So I know they have an older firmware, and not sure they auto update or not.

I was just getting around to trying them out.

I was trying to flash Blink LED first, then I couldn’t get it to work so I tried to put tinker on it.

I tried putting it in safe mode but I couldn’t get the purple lights.

I flashed it using DFU mode following this guide and now it shows up as running tinker. It also is able to be updated via the web.

Thanks for the help everyone.

1 Like

sorry, that “just” message was directed at “moors7”

glad you got it working though, now go make something :slight_smile:

1 Like