Web IDE not flashing [Photon]


#1

I have been unable to flash from Web IDE for the past hour or so. I have tried with multiple devices, removing and adding them from the account - nothing gets it to flash from Web. I can flash from particle-cli, but my code is on the web so that’s the issue.

I have a lot of libraries that would make flashing locally a pain.

Is anyone else having trouble flashing through build.particle.io web IDE??


#2

I am having this problem. I am unable to flash from either the web IDE (“Flash Unsuccessful”) or CLI (“Flash Failed”).

I was able to get Tinker back on the Photon and it’s functional (e.g. blinking the LED) but can’t get any other code to upload. I even tried the Web Blink example.


Issues with the online ide [RESOLVED!]
#3

Would verify(ing) not work as well? It was all just working then it just stopped.


#4

@cuzzler Getting an “Error: Could not compile” error for verification as well.

@potatotron I can get to tinker as well, but nothing from Web IDE. So, same issue.


#5

+1 on Web IDE problem. This seems like the same problem from Jul 26 that was resolved where the build farm had a memory leak.

I am getting “Error: Could not compile. Please review your code.” on the Blink an LED example.


#6

BTW, since something is wrong on the cloud side – Do I have no way of uploading my code now?


#7

This should be fixed now guys, thanks for your patience.


#8

Back in action, thank you!


#9

Update: Be sure to always mark it in the IDE to flash to (star) after reclaiming the photon… sorry.

Seems to be the same Problem over here. Newest FW, Photon. 
No Flashing over the IDE - flashing tinker from the app works.

#10

Still happening for me. The only time I can get it to compile is if it is completely and utterly identical to the example code. Otherwise it gives me “Error: Could not compile. Please review your code.” I am very mad, as I payed $50 for an Internet Button and I cannot program it. Please fix this, as this is a horrible error preventing me from doing literally anything. I cannot get the desktop IDE, as I am programming for school from a chromebook.


#11

@ButtonIsLife, cool your jets there!! The folks here in the community would love to help if you take the time to explain what you’ve done, take some screen shots of the problems and work with us to help you. I personally have had no problems with internet buttons so there is light at the end of the tunnel!


#12

One tiny step often forgotten when only owning one device is to got to the target icon and select your device as target and select a valid system version.


#13

I have screenshots. The build page is the only one open. I have just opened it and have clicked nothing but compile. I have not edited it in this session. Here are the screenshots:




My code is too long to fit into the post with the dumb indent syntax, (and I don’t know how to share apps with the online IDE) but the link is here. Thanks, if anyone can help, or if the devs can fix this, that would be great. Not being able to use my $50 internet button is extremely frustrating.


#14

Can you open the target drawer (third from the bottom up) and post a screenshot of that?


#15

Sure.


#16

The screenshot is here:


I haven’t claimed any devices yet. They are still being shipped. Still, I would like to be able to check whether my code compiles without owning a device.


#17

That’s exactly the reason, since you have no target selected the build farm has no idea what platform it should build for.
You code could compile for a Photon but not for a Core, but without knowing the target, the compiler wouldn’t know either way.

Hence my previous comment

But your initial comment

You cannot programm it because you have not got it yet, not because Particle has done anything wrong!!!


#18

Still, I’d like to be able to select device to compile for even without having one. Anyways, it is working now. No need for device selection. I believe something was interfering with my internet connection, probably school web-blocker. Anyways, thank you guys. Working fine now. Sometimes. Still, I have confirmed it will at least work 70% of the time.


#19

I am facing the same issue. even though i have specify the target device.


Till yesterday afternoon it was working fine but after that i am getting error. and i have checked the community solutions to resolve this issue but didn’t find any proper solution.


#20

Your device desperately needs updating its device OS - 0.5.4 is aaaaanciean.
Due to that outdated device OS you are running into an issue that’s also in connection with not fully applying the documentation’s instructions/warnings
https://docs.particle.io/reference/device-os/firmware/electron/#particle-function-


vs.
image

Your Particle.variable() syntax is also outdated. It should be

  Particle.variable("cell", value);

You also don’t show what the reported error was - I guess that would have give a clue in that direction too.
In your screenshot you should also reveal the settings hidden behind the > button next to your device name surepark.
There you can also check whether the device is online/reachable by hitting the SIGNAL button (or the :bulb: icon next to the device name in the status bar)
image

The empty/black circle between device name and device OS version also suggests your device is not online.