The core is looping flashing white then solid blue over and over

I’m stumped. I have a core that has been working correctly until yesterday when I just saw the little blue led lit only. The RGB led was not lit. I tried a reset, factory resets (5x) . Doing the factory reset it does go to yellow then flashes white. I release the mode button then the RGB led does this. Rapidly flashes white then it turns solid blue then flashes white then solid blue. I’m stumped.

I tried to claim my core with my android phone but it does not see the core.


It sure look weird. Can you power off and perform a factory reset again?

I powered it off and did another factory reset. sigh… it still does the exact same thing. Flashing white then solid blue then flashing with then solid blue over and over. It seems stuck.

Can you enter DFU mode? Hold both buttons, release only reset and wait for flashing yellow.

What did you connect to the core?

Ok… I did as you requested. I held both buttons and did wait for the flashing yellow. It does flash yellow. I originally connected the core to my desktop during my first 3 factory resets. I then used a power supply with the white spark core usb wire for my recent factory resets. I hope that was what you were asking.


Do you have spark cli? You can performspark flash --usb tinker`` to change to user firmware.

If you are on windows, I have a tutorial to update tinker as well :slight_smile:

I don’t have spark cli. I do have windows. A tutorial reference would be great. thnx

You can follow this tutorial and use Option 2 to flash tinker instead.

I’m hoping that would solve the issue!!

1 Like

Thanks. Will try it next day so I can be awake. thnx again for the quick help. I’m hoping this it.


Thanks for helping @Argorob - @kennethlimcp!! Get some sleep!

Sleep at 8:20pm?! C’mon @Teke :stuck_out_tongue:

1 Like

First… Thanks for the quick help kennethlimcp. but Sigh… I’ve tried yesterday and am trying tonight following your instructions and Zadig keeps saying in the list of devices “Unknown Device” and when I click “Install Driver” If fails everytime. The spark core is flashing yellow and is showing up in my device manager under Universal Serial Bus Controllers as Unknown Device.

This is the Zadig recent log:
libwdi:info [SelfSignFile] successfully signed file 'C:\Users\Rob\usb_driver\’
libwdi:info [SelfSignFile] successfully deleted private key
Driver Installation: FAILED (Resource already exists)
11 devices found.

Did you put your code in DFU MODE (blinking yellow)?

Yes… It is still blinking yellow. Zadig device list says unknown Device.

I get a “The Driver Installation Failed” error trying to use the Zadig tutorial. Do I have a severe issue with my core that I cannot bring back? Thoughts? I would like to flash my core to factory reset. I tried the hold mode and reset procedure but it just goes back to flashing white for a while then solid blue then back. I’m willing to send my core back for inspection not asking for an exchange at this point since it was working fine for a few months. thnx

Zadig log:
libwdi:info [RemoveCertFromStore] deleted existing certificate ‘CN=USB\VID_0000&PID_0000 (libwdi autogenerated)’ from ‘TrustedPublisher’ store
libwdi:info [CreateSelfSignedCert] created new self-signed certificate 'CN=USB\VID_0000&PID_0000 (libwdi autogenerated)'
libwdi:info [SelfSignFile] added certificate ‘CN=USB\VID_0000&PID_0000 (libwdi autogenerated)’ to ‘Root’ and ‘TrustedPublisher’ stores
libwdi:info [SelfSignFile] successfully signed file 'C:\Users\Rob\usb_driver\’
libwdi:info [SelfSignFile] successfully deleted private key
Driver Installation: FAILED (Resource already exists)

I have the exactly same problem.

I tried the method which @kennethlimcp provided(Thanks!), and running the bat file while RGB is yellow, but console show me this message -> “This is the end of the utility. Please re-run if you encounter any issues!”

Any idea to save my Spark core? :frowning:

@abue172, can you give a description of the RGB led on your core and is this happening right out of the box for a new core?

Looks like i forgot to put the dfu-utils.exe into my System32 folder :wink:

But this mehod didn’t make anything change.
It still looping blue…


This happened after i flash my code through WEB IDE -> RGB LED become RED -> OMG! nothing changed after reset! -> Factory reset Go! -> looping flashing blue( just like listening mode)

Was the core flashing white when you performed a factory reset?

Try performing a factory reset again and see what happens