Spark core not connecting and blinking red

the sparkcore keep blinking red very fast for a while then keep blinking white for a while then goes back to blinking red and the cycle continues ,any help please ? as i have a project presentation soon and its not a good time for the sparkcore to do crazy stuff

Hey there! Trying performing a factory reset and see how it goes.

thanks for the reply but how can i do that ?

i did the factory reset and still same thing …still blinking red nth changed

Hmmm… did the core flash white rapidly during the factory reset?

yes it did

@zizosakr, would you mind posting a video of you doing a factory reset and what the video does after the reset? Thanks!

suggestions on how to fix this plz asap

Video marked private. Would you mind fixing that and I’ll be happy to help!

can u see it now , is it visible ?!

Hi @zizosakr

Yes, we can see your video now. @harrisonhjones will have a look too but it looks like a key problem to me. If you have the Spark command line tool installed, you could try this:


@bko thxx for the help but unfortunately the issue is not solved , its still blinking same way nothing changed … whats the other option i can do ?!

Did you have a chance to run the key doctor? What was the result?

yes i did right now , did factory reset then ran the key doctor then tried to connect to the wireless network and it took forever to connect…kept flashing cyan rapidly for a while then kept flashing red for a while and the cycle repeats

This is really @kennethlimcp speciality but I would try to patch the TI CC3000 just to be sure:

spark flash --usb deep_update_2014_06

By the way you have to be in yellow flashing DFU mode and DFU has to work (needs a driver on PC) for these commands to work. Another good thing to check is to put the core into DFU mode and then do a dfu-util -l to list the USB devices that DFU understands. You should see the core (and possibly other devices).

1 Like

Looks like bad keys indeed.

be sure to use the command spark keys doctor CORE_ID in DFU mode (blinking yellow) via Spark-cli

Can you paste the commands and the output you ran here just to be sure? :wink:

1 Like

i did the “spark flash --usb deep_update_2014_06” command and for the past half hour its still loading , does it usually take that much time ? or should i quit and try it again ? right now the command is loading and the spark is blinking yellow

when i did the "dfu-util -l"command it told me Reference Error: dfu is not defined…