LED flashing red rapidly for 20 seconds, then cyan 2 or 3 times, then start over

Here’s a verbatim copy of the email I sent hello@spark.io, hope you can help me!


At work we have a couple of cores and we usually borrow and take them home for the weekend to keep on tinkering.

The core I brought home doesn’t seem to be able to connect to the cloud.
I use spark-cli to set them up and had no problem setting up the previous core I used, but this one, after running spark config, the program takes me through the usual steps, but after putting in the wi-fi credentials, the core saves them and then it says it should be breathing cyan, but I only get 20 seconds of very rapid red flashes followed by a couple blinks in cyan and then the cycle starts again.

I tried to check with my colleagues to see if this core had been modified for use with the local cloud but couldn’t get any answers.

Here’s a list of the stuff I tried:

spark flash --factory tinker
spark flash --usb cc3000
spark flash --usb tinker
spark keys doctor <core_id>

Everything I ran worked successfully, but I still can’t get my core to connect to the cloud.
The core was correctly working on Thursday at the office, so I don’t know what else to try!

Thank you!

Is it possible that it is pulsing white, not cyan? Do you have a multimeter so you can confirm 3.3V between the 3V3 and GRD pins? Also check your supply voltage to ensure it is between 3.6 and 6V.


It is not pulsing white, I put the core in factory reset mode to see the difference in colors and it is not.

It is the same cyan color that should be “breathing”, but only for less than half a second before it starts blinking red very rapidly.

I don’t have a working multimeter right now, but I’m using the same power source I used with the other core (an iPhone charger) with the same USB cable.

After your comment, I also tried with different cables and different USB chargers (and my computer’s USB ports), always experiencing the same behavior.

Red or…orange? Sounds like bad keys if it is a new device!

No, it’s definitely red.

Core is not new, but it may have been tinkered with to work with a local server.
Either way, I tried the spark keys doctor command and it is still not working.

Did you do a spark keys server with_spark_cloud_key.der?

Need to revert the :cloud: keys as well

1 Like

Thanks for the tip, I haven’t done that. After doing it and going over the spark setup command again, the core is stuck on a rapid-flashing cyan, which, according to the website, means it is doing the handshake with the cloud server.

EDIT: on closer inspection, it seems as if it flashes rapid-cyan for some time (can’t time it), then flashes regular cyan, alternating between rapid and regular, and starts over just blinking cyan.

Is there any other command I may be missing?

Thanks again!

If you have never had a core work with this router, I would make sure that

  • It is not trying to move your core to 5GHz instead of 2.4GHz. If you can name the SSIDs differently in your router, that will ensure this.
  • The CoAP port (5683) is open on the router
  • Your router is set to Channel 11 or lower
  • You are not using WEP for security

Basically, make sure everything on this page is taken care of:


1 Like

I’ve had other cores work here in my network without any issues at all, that’s what’s baffling me!

1.) do a spark keys server cloud_public.der Using the spark cloud public key

2.) next do a spark keys doctor CORE_ID


Worked like a charm! The core is now breathing as it should.
Thank you for your help!