[Solved] Flashing Red after Handshake (since this morning)

Since this morning i have stability problems (also with the base tinker app) connecting my cores (2 of them)

Normal connection works (1 out of 10 times) (green -> green flashing -> Cyan blink -> cyan flash -> cyan breath)

More often (on booth cores) is : green -> green flashing -> Cyan blink -> cyan flash -> red flash -> cyan flash

I have read that red flashing seems to be a problem with the keys, but every few trys, it works. Is this possible ???

My cores that have all been working are having trouble connecting to the cloud.

They go from fast flashing cyan (Handshaking) and sit there for a while before going to red fast flashing?

They then reboot and got through the process again, sometimes they connect for a little while but minutes later they will be back to handshaking and crashing.

Happening here too!

I too, believe there are some problems. My Core has also been disconnecting every couple of minutes, as can be seen here: (it doesn’t show ‘offline’ since it reconnects before the offline check has taken place)

Time to call in reinforcements: @Dave, @jgoggins, something wrong on the server end perhaps?

1 Like

Yup, I thought it might not be a local problem… thanks for posting.

And was thinking I’ve killed it

I’ve too have been having these problems with the cores I have powered up this morning.

Hey guys, i have emailed the team and hopefully someone jumps in fast enough.

Sorry about that!

1 Like

Uff glad to see this :slight_smile: thought I messed up my code :stuck_out_tongue:

Same problem here in Princeton, NJ

South Jersey reporting the same issue. Thought I was just blowin up cores.

Same thing in Central Ohio. Problem is my remote cores are probably draining their batteries at an alarming rate!

.

 Devices unable to connect

Investigating - The ops team is responding. 

Feb 2, 08:27 CST

from: http://status.spark.io/

Yes, thats also an upcomming problem on my installations, cause the Error takes place during a Call to connect().

Also interesting from my site: the Connect-State for the cloud is “connected”, but the LED is flashing RED.
So from software side i’am not able to differentiate or detected the “RED Flash” (to switch all OFF after such an timeout)

Strange undocumented high speed led flashing 20 sec cyan then 20 sec red.

This is what I have:

.

 Resolved - There was a problem with the device service's database connections. Everything's back online now. 
        Feb 2, 08:39 CST
2 Likes

Thanks. Now it works again.

I’am wondering why the Status Page at

http://status.spark.io/

Mentions everything is ok and running (since this morning)…

Hi @softmeter

The text that @kennethlimcp quoted in his post above “Devices unable to connect…” is from the status page at “Feb 2, 08:27 CST” so I think you just missed the brief time on the Status page from when Spark started to investigate the problem to when they fixed it.

I do know they have a rotating 24/7 duty pager system where someone gets a page day or night if there are problems, not all problems trigger the paging mechanism if they have not seen it before.

2 Likes

I first checked the status page (5 hours ago). Maybe i have missed the Information. Now it’s working fine.

Howdy folks, sorry for the troubles and thank you for reporting them here.

Our automated alerts did not catch this and wake us up like it should have. The reason it didn’t is due to the fact that connectivity issues started out intermittently and grew gradually over the course of several hours and did not affect our alerting cores until the failure rate was high enough.

As always, we’ll be conducting a more detailed analysis of the root cause. We’ll post a summary here.

Thanks,

-joe

2 Likes