Unidentified red LED pattern on first use. Cloud handshake?

Hello everyone,

I received my Spark Core this week and yesterday I finally found time to unbox it. Unfortunately, I can’t possibly get it to work at this point.

Using the Spark Core app, TI app and serial, I’ve made it connect with my wifi, but the same thing keeps happening: pulse white, then flashing green, followed by flashing cyan, ultra-fast flashing cyan, ultra-fast flashing red, and then whole thing repeats. I’ve tried to update the firmware using the guide on the forum. I have also tried updating the CC3300 firmware following the steps in the post. All to no avail. Probably because it has nothing to do with it, haha, but I don’t know where else to turn but the forum right now, because there seems to be no other posts or guide describing this problem.

Have you guys got any idea on what this LED pattern is telling me? Or maybe some other steps to troubleshoot this?


  • Tom

We had someone with a similar issue but not sure if the mode button is stucked.

Can you try a factory reset to clear all the settings and do a Smart Config again? If that works and your core managed to reach breathing cyan… woohoo!!

Otherwise, the factory reset firmware might be corrupted and we can attempt to update it :slight_smile:

I have done a factory reset already. Multiple. Literally, loads :P. After manually updating the firmware using dft-util and in between using different ways of Smart Config like I described in my start post.

I have yet to reach a breathing cyan for the first time with this thing.

Can we have a video? Firmware as in CC3000 or the factory reset firmware too.

If you reached blinking cyan i dont see why there’s an issue with the keys.

Hi @zoef__,

It’s possible your core is having key issues, there’s a troubleshooting post here:


Hi David, thanks! I’ve followed the steps. Step 10 told me to send you my public key, so I did.

No change yet though…

Hi @zoef__,

Thanks for sending me your key, can you send me your core ID as well? The CLI also lets you add a new key in this situation as well (that’s what I use when people send in public keys), but sometimes it can take me more than 10 minutes to respond to emails. :slight_smile:


Sounds like you guys need some interns! :wink:

1 Like