Rapid cyan followed by rapid red flashing [After switching back from Local Cloud][Solved]

Ordered 3 Spark Cores, 2 of them work fine, but I have issues with the 3rd one:

The led is blinking rapidly (cyan) for a few seconds, after that rapid (red) for a few seconds and so on.

I have tried a factory reset with the two buttons, and have done a firmware reset using dfu-util, all to no avail. I’m afraid that there’s something wrong with the hardware of my 3rd one…

Hi @wouter,

I’m sorry to hear it’s blinking red! Usually that means there is a problem with the keys, can you try installing the spark-cli, and trying the keys doctor? ( https://github.com/spark/spark-cli )

spark keys doctor your_core_id
spark keys send your_core_id core.pub.pem 


1 Like

Yes, I was toying around with the local cloud while setting up my Sparks. I forgot to re-upload the cloud.pem key and it’s back to normal. I expected that restoring the firmware would reset the keys somehow, my mistake.

Thank you!

1 Like