Spark Core first use, stuck in loop; rapid flash cyan - yellow - red

First use of Spark Core, connected via iOS app, entering SSID and password. Residential network, other apps have internet access. Got blinking blue, solid blue, blinking green as expected. From there dropped into infinite loop of:

  • rapid flashing cyan (blue/green die)
  • rapid flashing yellow (green/red die)
  • rapid flashing red (red die)
  • repeat.

Never got to breathing cyan. Performed factory reset (? = hold both buttons, release RST, wait til turns flashing white). Connecting again via iOS app yields same result. From forum perhaps this is an encryption key problem, but did not find post with this blink pattern.

Am hardware guy, use small words please.

It sounds like bad keys. Can you try installing Spark-cli?

1 Like

Found instructions for CLI install here: http://docs.particle.io/core/cli/
Installed node.js.
Attempted next step from above link:

# how to install the particle-cli
$ npm install -g particle-cli
$ particle cloud login

Errored out with:

C:>npm install -g particle-cli
npm ERR! Windows_NT 6.1.7601
npm ERR! argv “C:\Program Files\nodejs\\node.exe” “C:\Program Files\nodejs
\node_modules\npm\bin\npm-cli.js” “install” “-g” "particle-cli"
npm ERR! node v0.12.3
npm ERR! npm v2.9.1
npm ERR! code E404

npm ERR! 404 Not Found: particle-cli
npm ERR! 404
npm ERR! 404 ‘particle-cli’ is not in the npm registry.
npm ERR! 404 You should bug the author to publish it (or use the name yourself!)

npm ERR! 404
npm ERR! 404 Note that you can also install from a
npm ERR! 404 tarball, folder, http url, or git url.

npm ERR! Please include the following file with any support request:
npm ERR! C:\npm-debug.log

Suggestions?

Not sure if particle-cli is released yet but i think @nexxy did it already

@kennethlimcp that is correct!

Apologies, @steffenn. You must have happened to try and install the particle-cli in the time between the docs were updated and the package was published on NPM.

Let me know if you have any more trouble with it!

That did the trick, thank you. Recall I am following “http://docs.particle.io/core/cli/”. The [npm install -g particle-cli] command executed successfully. The next step [particle cloud login] also went smoothly. Skipped the steps under “Advanced Install” (installing dfu-util and openssl) since I took them to be optional by the name.

Executed [particle setup] but failed with “No devices detected via USB.” Held MODE button until flashing blue, tried again, same result. Did MODE/RST factory reset until white then flashing blue, tried again, same result. Yes, SparkCore (ahem ParticleCore) was plugged in. Did I miss installing a USB driver somewhere?

Do I need DFU-util and OpenSSL? If so, kindly confirm I need 64-bit versions — Node.js installed as 64-bit on my machine. Recalling I am a hardware guy, no tip is too obvious. Thanks.

Can you do a ‘npm update -g particle-cli’? Think there was an update for DFU issue

Yes you will need DFU-util. Search on the forum for tutorial to install :slight_smile:

  • [npm update -g particle-cli], seems to work although messages aren’t super clear.
  • Used Zadig to install dfu-util for CORE-DFU (Core attached, blinking yellow, listed as CORE DFU in Win Dev Mgr), added to PATH.
  • Installed openssl-1.0.2a-x64_86-win64, added to PATH
  • Try [particle setup] but get “No devices detected via USB”. (Core attached, blinking blue)
  • Help???

Note, put core in DFU (blink yellow) and run [dfu-util -l] gives:

dfu-util -l
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Found DFU: [1d50:607f] ver=0200, devnum=13, cfg=1, intf=0, alt=1, name="@SPI Flash : SST25x/0x00000000/51204Kg", serial=“8D7257864955"
Found DFU: [1d50:607f] ver=0200, devnum=13, cfg=1, intf=0, alt=0, name=”@Internal Flash /0x08000000/20
001Ka,108*001Kg", serial=“8D7257864955”

Also, uninstalled Win Dev Mgr driver for [Spark Core With WiFi] and reinstalled from https://s3.amazonaws.com/spark-website/Spark.zip. Windows reports success, no change in “No devices detected via USB” error. Note, when device switched back and forth between normal (blinking blue) and DFU (blinking yellow), Win Dev Mgr recognizes and lists device as [Spark Core With WiFi] or [CORE DFU] respectively under [libusbK USB Devices].

Note, all installs done as 64-bit. ** Neither Python 2.x nor Visual Studio are installed, if that matters. **

Also,

particle serial wifi

! serial: No devices available via serial

Still can’t claim core.

TLDR version:

  • In DFU mode (flashing yellow) [dfu-util -l] finds the Core.
  • In Listen mode (flashing blue) [particle setup] reports “No devices detected via USB”

Any suggestions what might cause this? (additional detail in previous post)

Are you using a photon or core?

I am using a Core.

I am having the similar issues after installing the particle CLI and I am getting error when I am trying to connect to spark.

spark setup errors out and now my spark is flashing red/yellow.

The particle CLI is now installed and works. Used [particle setup wifi] to configure Core (yes, Core, not Photon). Looked good but ended in tragedy:

Serial said: Awesome. Now we’ll connect!

If you see a pulsing cyan light, your Spark Core
has connected to the Cloud and is ready to go!

If your LED flashes red or you encounter any other problems,
visit https://www.spark.io/support to debug.

Spark <3 you!

timed out on Particle <3 you!
Something went wrong Serial prompt timed out - Please try restarting your device

No <3 from the Core. Here’s the best part. The Core is now left in the exact same condition as the failed configuation from the iOS app that started this thread, infinite loop of:

  • rapid flashing cyan (blue/green die)
  • rapid flashing yellow (green/red die)
  • rapid flashing red (red die)
  • repeat.

Did a factory reset and repeated [particle setup wifi] with same result.

@kennethlimcp, earlier you said “It sounds like bad keys. Can you try installing Spark-cli?” The CLI is working, can you suggest next steps?

OK cool that you have particle-cli installed!

Can you place the core in DFU mode and do the following:

  • particle flash --factory tinker
  • particle flash --usb cc3000 (device will blink magenta and revert to yellow)
  • particle flash --usb tinker

Let me know what’s the led status after doing this :smile:

In the meanwhile I found this thread and followed it: [Solved] Can’t connect Spark Core to Spark Cloud + can’t claim core

Resulted in breathing cyan. Breathing sigh of relief.

@kennethlimcp, do you still want me to run the [particle flash *] commands you list in the post above for your benefit?

You can do that if your core is an old version and that will bring things up to the latest. :wink:

Have fun!

How do I tell if the Core is an old version?

It’s hard to really tell but there’s really no harm to run those patch and you only need to do it once. :smile:

The really obvious difference is a white and black core. White is kickstarter version so everything inside needs some updating :smile:

OK. Thanks for the help.