Newbie Help - Was Working Now Not

I have a Spark Core that was working just fine. Then I started a project and in the process really screwed things up. I had an open color on the LED (its been a bit so I forgot) and I’m pretty sure I shorted something out because the USB power supply needed to be reset in order to get enough power again.

Anyway I can’t seem to get the Core to show up on the app. I ran the reset procedure with the Mode button and the Reset button. Currently the Core is blinking Blue and I have been unable to connect with the same phone and the same App to it. Is there something else I should or could try? I did try the CLI but had trouble installing on my imac. I get a warning “Failed at the serialport@1.7.4 install script ‘node-pre-gyp install --fallback-to-build’.
npm ERR! This is most likely a problem with the serialport package,”

So I have two problems, but I was trying to figure out if I fried the radio and then had CLI / USB connection issues.

Any help would be much appreciated.

I ran into something similar with installing the CLI recently that was due to a node version incompatibility. Are you using nvm to manage node versions, by any chance? I was able to get it to build under node 0.10.x but not 4.x.

No I am not using anything a node manager (I don’t even know what a node manager is?)

I somehow got the my core to blink green steadily but it will not connect. I suspect at this point the unit is dead but i’ve had little help trying to diagnose otherwise. Any ideas? Please help.

To be able to do more troubleshooting you will need to somehow get Particle CLI up and running…
Recently I had similar issues when trying to get Particle CLI working, and installing Node version 0.10.29 fixed those errors you mentioned.

To get Particle CLI running try this:

  1. Install node-v0.10.29 from HERE
  2. In terminal run: npm install -g particle-cli

To verify if Particle CLI is installed you could run this:

$ particle --version

On my machine I get this version:


Now you cloud login to the Particle cloud using:

$ particle login

Then you could try to place your Core in DFU mode (connected via USB).

To place the Core in DFU mode, follow these steps:

  • Hold down BOTH buttons
  • Release only the RST button, while holding down the MODE button.
  • Wait for the LED to start flashing yellow
  • Release the MODE button

The device now is in the DFU mode.

Now run in terminal with the Core connected to your iMac:

$ particle flash --usb tinker

This should normally work… and will make sure the Core firmware will be updated and also put the “tinker” app back to your Core. If after the restart you see it flashing blue, that means it is in listening mode.

If that happens, you could run:

$ particle setup 

And go through the setup process to connect it to your wi-fi network.

Thanks I followed the directions and the result is a flashing green - but I still can’t seem to connect to it :frowning:

Any other ideas or thoughts?



Sorry I held the mode button until it started blinking blue but the CLI still doesn’t see it…

No devices detected via USB. is what I find in the first step of the setup. I can clearly flash it so something isn’t correct?


sh-3.2# particle flash --usb tinker
Found DFU device 1d50:607f
checking file /usr/local/lib/node_modules/particle-cli/binaries/core_tinker.bin
spawning dfu-util -d 1d50:607f -a 0 -i 0 -s 0x08005000:leave -D /usr/local/lib/node_modules/particle-cli/binaries/core_tinker.bin
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to

dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!
Deducing device DFU version from functional descriptor length
Opening DFU capable USB device…
ID 1d50:607f
Run-time device DFU version 011a
Claiming USB DFU Interface…
Setting Alternate Setting #0
Determining device status: state = dfuERROR, status = 10
dfuERROR, clearing status
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 1024
DfuSe interface name: "Internal Flash "
Downloading to address = 0x08005000, size = 79996
Download [=========================] 100% 79996 bytes
Download done.
File downloaded successfully
Transitioning to dfuMANIFEST state

Flash success!

Well we’re making progress…Good stuff :thumbsup: . At least know you got Particle CLI up and running.

Now… if you’re using OSX El Capitanknow that there is a problem with the USB serial monitor. So don’t sweat too much over it. Probably an update is in the works somewhere…

In the meantime, you could install Particle Dev. Because when using Particle Dev the serial monitor works.

Get Particle Dev HERE

Play around with it to get familiar, it is a great way of writing your code locally on the Mac and then either compile it or flash your devices. But the most important part is that it comes with a serial monitor built in. So you could use it to further troubleshoot your Core.

Good luck. :thumbsup: Let us know if it helped…

1 Like

In the serial monitor in the dropdown it only shows a bluetooth incoming port? It also never connects so could this be a problem with El Capitan as well?



Im still at a loss. I ordered a couple more Protons but that does fix whatever mess I have here with this Core?

Any suggestions?



Can anyone help? Is there a techsupport email address for Spark?



Been stonewalled here. Can anyone please provide some help? I received my Photon (sorry I said proton before) and got this one project sorta working. Not sure if my relay module is the issue or the power capacity of the Core vs Photon.



Now that you’re mentioning power… Have you tried setting up the Core with nothing attached? Perhaps the peripherals are messing things up. Also, have you got the proper drivers installed for USB?

@heffneil, do a search in the community regarding El Capitan. I believe there are known issues. I will also poke the Particle Team to see if anyone can help. :smile:

Update to latest CLI for El capitan support.

Swap around USB ports and cable if it still doesn’t detect the device

1 Like

Thanks everybody for jumping in! Here are a few notes from me too:

  • The forums is a great place for this question to be sure, but you can always reach us at
  • If you have a core and you can’t setup wifi from the app, it could be because your phone is on a 5Ghz network instead of a 2.4 Ghz network. Try changing your wifi settings, or using a different network, or setting up over serial if you can.
  • If something isn’t working like you expect over USB (dfu / serial / etc), try a different USB cable. You’d be surprised how often the cable is the culprit.
  • I vaguely remember an issue with Core’s and USB 3.0 ports as well, so you might also try a different port, although I haven’t seen this issue on a mac.
  • If you’re connected via USB on a laptop, make sure the laptop is connected to power. Some laptops (like a Macbook Air on battery) don’t always love giving a device full power. I also seem to recall a very old version of Core firmware that didn’t ask for enough power. So a cell phone charger or other power supply might help.