Frustration in getting started

I just got the Core from SEEED and try to claim its key…whatever the fancy words SPARK and now Particle would like to call it. I cannot go thru the phone (TO DO SO) as my Android phone serves as the gateway to the internet for my laptop (with CORE connected to it). Then I tried the manual CLI way. Yet, the final message at the prompt said “not ok code 0”.

Now, I cannot proceed at speed with all these messy procedure. The Spark IDE for desktop needs the cloud to compile… when I get to the cloud, yet I need to claim the key…yet, the above goes into the picture. HAS anyone with many spare time to help?

Good product… should make life simpler!

Can you try installing the particle-cli or setup the core via a serial terminal?

@sam_desd, first welcome to the :spark: Particle experience :+1:
Sorry, for the frustration, but give the Core and its siblings some time to make it up for you :wink:

Now to your problem.
As you’ve already found out, you can’t do the claiming via your phone while it serves as your AP.
So you have to use other options like CLI.

If you’re on Windows you’ll need extra drivers (you’ll find a link at )
As stated there as well, your Core needs to be in listening (blinking blue) mode.

@kennethlimcp, where has the “TROUBLESHOOTING” section of the docs gone?
As I understool @sam_desd, he’s already got CLI.


Hi guys,

I am taking now about 6 hours just to get the claim… yet, no LUCK! I did install the USB driver successfully. However, using the Android Spark apps… it cannot detect any CORE despite the unit connected to my laptop with led blink blue.

I tried to install CLI… also failed in my cmd prompt with error code 0. In fact, I am now giving everything (as a technical person)… go to the site with internet/wifi, fill up the SSID AND PASSWORD… yet, frustration.

The node js was installed with the correct version according to the laptop machine, yet npm install…bla bla bla did not get anywhere.

Now, I am using the iPhone together with another person who is an engineer… just to work out this superb device, the CORE.

I hope you are not chasing me out

This is really impractical … after about 7 to 8 hours, I just managed to claim 1 of 2 Core. I think you better improve the claim process 360 degree. Now I am doing the claim for the 2nd one. I hope I can sleep tonight. And I have tried via Android and iPhone more than 30 x for the 2nd one. Still no luck


The entire :spark: team is busy at Maker Faire bay area and there’s limited support at this point in time. We are here to help and it shouldn’t take so long to setup. I would suggest that you calm down and let us assist you since the rants wouldn’t help much. :wink:

1.) Install a serial terminal like Putty. If you have Arduino IDE installed, the serial monitor works fine as well

2.) Perform a factory reset and the core should blink blue

3.) Hit i in the Serial terminal to get your device id

4.) Hit w and follow the steps to send in Wifi credentials

5.) Wait for the core to connect to the Wifi network and it should be breathing cyan.

Let us know if this did not occur.

6.) Once the core is breathing cyan, go to the Web IDE and claim the core using the device id copied from step 3.

Hope this helps!

Hi Kenneth,

Thank you, I will do that and report for any failure LATER. I do not know whether I still can write under this title OR open up a new topic, however… let me JUST say it here:

  1. I wrote a simple program for the CORE to communicate with another MCU via the UART port. And to cut the story short, to my surprise … the CORE will only works once it gets the internet access. Meaning that… any time during its running and SOMETHING happen to the WIFI/Access point OR the internet services (telecom company) or your server… the CORE will stop its operation.

I have proved this that the CORE stops sending and responding to the other MCU as I turn OFF the internet router… and once I re turn the router… I get the CORE to function again.

I think this is very hard facts to accept as we are providing home control system… and due to any of those failure… WE WILL SLEEP STANDING!

In general…the overall issues are:

  1. No internet… meaning I cannot compile my application
  2. Failed to install the CLI on Windows 7 and 8 using npm …
  3. Very long process for the claiming… what if I need to do for 1000 units of the houses
  4. Tightly attached to the network that for the first time I made the device claim… even though this can be changed, yet god knows if it is easy OR as difficult as doing the claim
  5. Worst of all, it runs with internet and your server ! It can never run without your server AS a standalone module. Even though cloud is needed BUT to me, it not a must. I need the UDP and TCP over the wifi only… well most of the time… but the I do not need cloud all the time. By doing this you tie my customers to must have your cloud… which is impractical again

My friend, you have a good device, yet made impractical from my point of view. As I said, you all should liberize the usage of that great CORe/Photon to the needs of your customers.

Thank you


  1. This was true in the early days, but now we’ve got SYSTEM_MODE(SEMI_AITOMATC) and SYSTEM_MODE(MANUAL) to help you out there :wink:
    1 again) You can use a local toolchain to build locally, too.
  2. No idea what your actual problem cause might have been - but it’s not a general problem for all users (don’t generalize)
  3. That’s not everybody’s experience, but some people do have similar difficulties. For Core fleets, you can contact :spark: Particle direct, they’ll help you out, as they did with others.
  4. see 3
  5. There is an open source local server that would free you from that (and again see 1.a)

You may not yet know all the ins and outs of the :spark: Particle product line, but there is more to find out, before you should cast a vote like this :wink:

Hi Kenneth,

No good news. I used the Arduino serial monitor… I reached the SSID and it stops there. The Arduino serial monitor also stuck no where. I repeated few times, yet the same.

However I managed to copy the device ID.

What shall I do next?

Thank you

What colour is the core in? Blinking green? Blinking cyan?

You should try using a different serial port terminal emulator–the Arduino serial monitor sometimes doesn’t work right. Looks like your are on Windows, so PuTTY would be the usual choice.

1 Like

Hi ScruffR,

Please tell me more on:

  1. How I can do local compilation? I hope the process does not need the Linux machine/OS and tools related to its environment… as I am pure windows user

  2. And how I use the open source local server?

Please provide me some links and detail info

By the way, is there a way to run it without the SHADOW of having a server? I mean just having it as standalone device giving UDP and TCP … no cloud?

Thank you

Hi Kenneth,

After I key in the SSID… no colour at all displayed by the CORE

It seems like stuck for some long time after the SSID sent… neither it ask for the password as I would expect next

Thanks bko… I will see

There are some threads on this forum

I, for example, am mainly using Windows 8.1 also and have played with Eclipse and the GCC toolchain.
Others use Netbeans or just command line.

For the local server @kennethlimcp is the one to ask - he’s really into that.

And if you only want TCP/UDP you’d go for one of the SYSTEM_MODEs mentioned above - that’s a breeze too.

1 Like

Hi ScruffR,

Thank you thank you very much. Appreciate your kindness. It is of my prime concern to get just the UDP and TCP to run first in a standalone mode… I will go for it!.

Do me little favour about getting into system mode… can you give me the url or anything that helps me recover from my thirsty?

Thank you again. I am in short of time for the demo

For system modes:

For firmware in general including UDP and TCP:

1 Like

Thanks @bko, for answering this :+1:

Just a word of “caution” - don’t believe this, it will be updated soon, since it’s not actually blocking :wink:

This connection will block until either the device connects to the Cloud or an interrupt is fired that calls Spark.disconnect().
1 Like