[SOLVED] Issues with getting started, claiming problems


For a minute, I was let down by this device… but then I realized this is a startup and that support is limited

First off, the spark core is a unit with a seperate antennae

  1. Plug unit in can get breathing cyan, it will even listen for my iphone, use the data, then not be claimed.
  2. Cant claim core in iOS… try again… etc
  3. Tried manually assigning the driver in USB then use tera term to get the ID, could not get the ID but I did get the driver signed.

Now Im basically up the creek without all of the dev tools…

cant flash anything, cant find the ID… both of which are needed for me to do anything with this device…

Hi @potatonet,

I’m happy to help get you started. A number of backers bought u.fl cores, which are specially designed to accept an external antenna. The core is also available with a built-in chip antenna! :slight_smile:

When the core is resetting, as it connects to your network, it sends out an mDNS broadcast with the core ID. If you reset the core a few times while trying to claim it with your phone you might have more luck. Also make sure your phone and the core are connected to an 802.11b/g network, and that your phone isn’t in 802.11n mode.

How are you connecting over serial? Where did you run into trouble? What kind of computer are you on? etc. http://docs.spark.io/#/connect/troubleshooting – Was your core in listening mode when you connected via serial? No prompt will appear when you connect via serial until you hit “i” or “w”.

You also don’t need the Cloud to flash anything to your core if you really want, you can always build and flash locally if you prefer: https://github.com/spark/core-firmware :slight_smile:


1 Like

Hey @potatonet, if you are on Windows you might try following this guide to make sure your driver is installed correctly: https://community.spark.io/t/installing-the-usb-driver-on-windows-serial-debugging/882

If you uninstall and remove all drivers first, you can also try installing the Zatig driver which works for local development and serial over USB. http://zadig.akeo.ie/ You’ll want to install the WinUSB driver for the Spark Core with Wifi when it shows up in the main dropdown box.

Also it needs to be in Listening Mode before it will try to connect over serial. This is a slow flashing Blue LED. You can reset the device, and hold the mode button until you see the blue LED, then let go. Make sure your Tera Term is closed while you are doing this… then open it and try to open your serial port at 9600 baud.

Also as a user of the Spark Core, I’d like to say that :spark: Spark Devices is a startup, and their support is by far some of the best support I’ve seen from any company! :smile: This growing community will be sure to impress you as well!


I have my device ID,

Tried to claim core online, nothing…

About to break out a rasberry pi, because at least those are consistent.

I run a business, a dev platform for running tests is hardly a solution for prototypes

Better luck next time, if I dont just throw it away first

I’ll mail you a prepaid envelope to throw-it-a-my-way…

Seriously though… if you have the ID and you can get your Core to Breathing Cyan you are just steps away from claiming it.


Click this:

When I did this last step once, it failed… but I tried it again after restarting my Core and it worked. Not sure why that was, but please don’t give up. The Core is an amazing piece of hardware.

1 Like

Thank you @BDub ! I would also gladly buy an extra core or two @potatonet , or you could ebay it ( http://www.ebay.com/itm/Spark-Core-RARE-Arduino-Compatible-WiFi-Development-board-NEW-/331119918688?pt=LH_DefaultDomain_0&hash=item4d1848fe60 )

Your core must be online and breathing when you claim it, it’s part of a protection to try and make sure the right people claim their own cores. If you still can’t claim it, email us at hello@spark.io with your core id and we’ll gladly help.


I agree with potatonet. This device does not work properly and is far from stable. It is an Edsel. I return to my Arduino and Beaglebone Black and dump this device. It has cost me too much precious time. Goodby.

Hi @Marcel,

Thanks for the feedback. I’m amazed at how far the community and the platform has come in a year, but we’ll never stop improving it. :slight_smile: Best of luck!


1 Like

Ignorance is bliss, isn’t it?

Unless you’ve posted under a pseudonym, it appears you haven’t asked the people who know.
As for now you are registered with this community for 10 (ten!) months and there were only two (#7 here and one other) rather rancorous posts with little room for dialogue.

This type of response is not much of help, coming up with a quote Mr. ScruffR, pouring oil on the fire. Talking about rancorous and leaving room for a dialogue […]. However if you feel personally offended I apologize.

Yes I am registered for about 10 months, have no pseudonym and have searched the community a lot for this problem and put a lot of effort in it to get it solved. I found a lot of information that should help but it didn’t. I tried to flash a new system on the Spark (this is one of the first shipments) but it failed. Maybe more for your convenience I failed getting a new system on it because I get the idea that this device can’t fail. I got straight forward information from Spark how to solve my problem but the pointers I got were all the same I already read on the forum and help pages.

Yes I’ve tried many times to get it installed the way the website stated and put a lot of effort in this device to get it working with no luck. Changed router brand, worked without security setting and with more than 3 different routers. Used the Apple App to get the device connected, used also the Texas Instruments App on the iPad nothing worked. Installed the node.js, dfu utils with no positive result. There is no device I ever had in hand I spend so much time getting it working as the Spark.

Next year I get the new Spark version and I really hope to get the new one working. The Spark idea is good but you must be realistic that some devices simply don’t work.

BTW. If you can’t stand the rand post I made, delete them you have my blessing.

@Marcel, when you say: “I got straight forward information from Spark …”, do you mean that you actually got in contact with Spark staff?

I’m a member of this community for not much longer than you and I got Cores from the first shipment, too. And that’s why I can’t believe that noone would or could help you with your Cores all that time.
For instance I recall that @Dave (I think it was him) even offered a replacement of a supposedly faulty Core of the early batches not only once, since they were perfectly aware that childhood problems do plague new products like the Core was back then.
So it might well be that yours is faulty, too - or it’s just a minor, but hard to find glitch.
But this could have been better dealt with via this forum in the early days - maybe saving you a lot of hassle and some hard feelings (like your other posts suggest).
The people from Spark and in this forum are exceedingly helpful and and kind AND the product is all but an Edsel - and it has matured a great deal since its early days.

Maybe Spark and I could convince you to give it another try, if you give us a chance and talk - and take the risk to be proven wrong :wink: in your previous judgement :smile:

I’d be interested if @potatonet has ever picked up on @Dave 's offer to email them and get personal assistance - since there is a huge gap between his last post (7 February) and yours (23 August) - but I guess not :frowning:

Hello ScruffR. I got in touch with - joe and - will@Spark from the Spark team and they really did a good job but all information they provided didn’t help. I got reactions on 9-feb, 16-feb, 17-feb, 1-mar, In the end I called it an Edsel. I was really pissed. Ok, they were offended and did not react anymore. It took me a lot of time to determine where it is going wrong and still I do not know, it keeps hanging on a green flashing led. It is connecting to the network and stays connecting.

Right at the moment I’m trying again getting my Spark claimed. I can access it by USB. I can get my id, put credentials in it but no connecting.

I installed node, and tried it that way. I can login with “Spark cloud login”, I get an access token, it can find my core id, I can setup my WIFI, the sentence is: Please wait until your core is breathing cyan and then press ENTER. But it keeps flashing green. I used also other routers as the Netgear WNR834Bv2 and Linksys WRT300N. It end alsways in green flashing. I opend port 5683 on the router. Please wait until your core is breathing cyan and then press ENTER. So it end again here.

@Marcel, I see - that explains alot. I’m sorry that you had and still so many troubles with your Core.
And since I have no idea what @will and others had already asked, and since I can by no means be as capable to assist as they can be, I might ask some annoyingly useless or already answered questions again - if you don’t mind :smile:

Have you got a uFL or a chip antenna on your Core?
Have you got a mobile phone that could act as your AP with WEP, just to prevent any issues with your network settings (saves you from having to alter any settings, too)?
What OS are you on with your computer?
What does the Core tell you, when you go into listening mode and connect with a serial monitor and send “i” to the Core?
What happens, when you send “w”? (enter SSID -> does it ask for WEP/WPA/open/…?)

That should be plenty for the (re)start :wink:

Heya @Marcel,

A very small percentage of cores have had manufacturing issues or had problems with the patch. There can also be issues when getting a core on your wifi for the first time. I think it makes sense to at least send you a replacement and see if a new Core works better. Can you email us at hello@spark.io with your shipping info and your current core id, and we’ll get that started?



The Core has a chipantenna.
I have an iPhone but my provider does not allow Internet tethering so the option is not available. I must check if my old Nokia still has this option.
OS is Win7
The Core tells id: xxxxxxxxxxxxxxxxxxxxxxxxxxxx
Security 0=unsecured, 1=WEP, 2=WPA, 3=WPA2: 3

This is what goes from the PuTTY screen. I can see it reacts on the input but after 7 sec… it starts flashing green and never stops, never turn cyan. Programming web interface still tells me cannot claim core,

Heya @Marcel,

If you do want to keep troubleshooting, make sure you’ve patched your core and are running the latest firmware, and make sure your access point is on channel 11 or below, using the CLI run:

//upgrade to the latest CLI, and make sure dfu-util is installed
npm update -g spark-cli

// put your core into DFU mode (flashing yellow)
//  if you don't have this yet, grab it here - http://dfu-util.sourceforge.net/
sudo dfu-util -l 

sudo spark flash --factory tinker

// your core should flash magenta after running the cc3000 command, wait until it flashes yellow again
sudo spark flash --usb cc3000

//then run this to put the latest tinker back on
sudo spark flash --usb tinker

// to enter wifi credentials again
spark setup wifi

Also make sure you’re not using WEP encryption on your network, it’s deprecated (no longer secure), and it can be really goofy with the keys (sometimes expecting hex instead of plaintext).


I have a Windows os that does not understand sudo (linux) or am I wrong? Is sudo part of the CLI I installed?

I use channel 8 on the router and wpa/wpa2.

BTW @Dave, @ScruffR my friend (USA) who has also a Spark tells me that it works at his business network but not at his home network. I live in the Netherlands.

For what it’s worth, I live in the Netherlands as well, and my Cores work perfectly :blush: I’m pretty sure we can work something out if you’re willing to give it another try with our help? A new Core might just solve it. Maybe you overlooked something in your previous endeavours which we’ll be able to assist you with. Just please don’t give up on the Spark, it’s way too awesome for that!

Windows indeed doesn’t support Sudo (as far as I know). You can get DFU-util here. If you run your commands in the same directory that DFU-util is in, you should be good on that part.

Have you perhaps tried to connect your Core outside of your personal network? Perhaps there’s some weird problem there, which can then be excluded.

Heya @Marcel,

If you’re on windows, make sure you have the proper dfu drivers installed if you haven’t yet, and use an administrator command prompt instead of sudo. ( https://community.spark.io/t/tutorial-installing-dfu-driver-on-windows-15-nov-2014/3518 )

It’s unlikely, but possible that channel 8 could have issues for 802.11b/g depending on your neighborhood. Typically most networks tend to fall on 1, 6, or 11 because those channels have no overlap. If you’re on channel 8 then you’ll be fighting for airtime with anyone on 6 or 11, etc.


Hi, Goodmorning.
@Dave. What I’m again doing is getting the Spark Core flashed by the book and the number. So I started to get the DFU utils installed. In the post of Kennethlimcp he checks for a proper installed DFU driver. Mine had a yellow exclamation sign in the hardware list. There was obvious something wrong with the driver. I deleted the driver and downloaded Zadig.exe. However after deleting and running Zadig I do not see the Driver after deleting. This part is clean now. I have to install the driver usblib driver again from scratch.

@Moors7. I first check if I overlooked something. I am human :smile: Next step is installing the USB-Lib driver and then the DFU-utils again. I have not tried to connect the Core at another wifi network.

Wifi. I made a inSSIDer screen grab. My router is NETBURNER. Pretty crowded.