Failed to claim core, Device is not connected

Been trying and trying to get this thing to work but i’m running out of ideas…

I’ve flashed on the latest updates e.g. cc3000… it’s breathing/pulsing cyan so i’m guessing it’s connected.

Whenever i try to add a core it says the device is not connected :confused:

Also when i run “spark serial identify” i get the following error:
Something went wrong Serial timed out
Potentially unhandled rejection [4] Serial timed out (WARNING: non-Error used)

Pulsing cyan means it’s trying to connect to the :cloud: but not succeeding yet.

Which security type is your network on?

Try connecting to your mobile hotspot and see if it connects well?

spark identify only works in Listening mode (blinking blue) and it’s for you to check on the core id.

1 Like

The network in WPA2 i’m pretty sure. I’ve also tried it on other routers and security types. Turned of firewalls.

I did try my iPhone hotspot and that worked so it must be something to do with distance potentially??

If it turned blinking cyan means it connected to the network but not to the :cloud: so distance is fine here.

Also, if it works with a hotspot, there might be some issue with the network configuration.

Are you on 5Ghz channel? Is the channel 11 and below?

actually it sounds like it did connect to the cloud - he said breathing/pulsing, which means that the cloud connection was complete.

sounds like you just need to claim your core, but you’re not able to get spark serial working. Do you have any other serial terminal tools on your computer? You can use the Arduino IDE, or GNU screen, or PuTTY on a PC, or CoolTerm on a Mac. Then open a serial connection to the Core (over USB) at 9600 baud, and then type i, which should return the device’s ID, which you can then claim from the web IDE

1 Like