Unable to claim Core over serial port. Connected to WIFI & flashing green, but not cyan

I’ve been struggling with my core for the couple days. I tried to do it with my android, but after pulsing blue then solid blue, it would start flashing green and eventually the app would say “No cores found”.

I’ve connected it to my computer and Spark setup works fine- the core is connected to WIFI according to terminal:

SSID: *******
Security 0=unsecured, 1=WEP, 2=WPA, 3=WPA2: 3
Wifi Password: *******
Attempting to configure wifi on /dev/cu.usbmodem1421
I said: w
Serial said: SSID: 
I said: *******

Serial said: *******
Security 0=unsecured, 1=WEP, 2=WPA, 3=WPA2: 
I said: 3

Serial said: 3
I said: *******

Serial said: *******
Thanks! Wait about 7 seconds while I save those credentials...

Serial said: Awesome. Now we'll connect!

Then it said:

Done!  Your core should now restart.
Please wait until your core is breathing cyan and then press ENTER

But then it started flashing green, occasionally pulsing white. I’ve tried following the instructions here, and searching this site but it just isn’t working. I’ve even tried hard resetting it, but that didn’t seem to help. The core has chip wifi, and I’m on a mac.

What should I do? Thanks.

edit: I tried just pressing enter despite it flashing green instead of magenta, and it said

Failed to claim core, server said  [ 'Device is not connected' ]
Please wait until your core is breathing cyan and then press ENTER

@rosshill can you place the core in DFU mode (blinking yellow) and then type particle flash --usb cc3000

The core will blink magenta after the flashing and eventually revert to blinking yellow. Now type particle flash --usb tinker and the core will reset once it is done.

Send in your credentials again and see if it works :wink:

Apparently I didn't find a DFU device? util said  
Error writing firmware... no dfu device found.

It’s flashing yellow and connected to my serial port :confused:

I put “particle flash --usb cc3000” in a new window of terminal, not after typing Spark setup.

can you try a dfu-util -l?

It should show some device connected. Or try a sudo particle flash --usb cc3000 (shouldn’t need sudo)


I tried dfu-util -l, but it says it isn’t a command. Sudo doesn’t help.

Looking at my Core I realize that the model is cc3000MOD, and trying particle flash --usb cc3000MOD returns

Please specify a firmware file to flash locally to your device

Side question, what does the MOD mean in the model?

Hi @rosshill

Looks like you do not have dfu-util installed or it is not on the path. I would search to see if you have dfu-util installed but if not you can get it from here:


Look in the releases directory for precompiled versions and find one for your platform.

1 Like

aghh… I have installed dfu-util with homebrew, entered particle flash --usb cc30001 which worked, then particle flash --usb tinker which also worked. Now in listening mode I did Spark setup and followed the steps until it started blinking green again and it said

Failed to claim core, server said  [ 'Device is not connected' ]
Please wait until your core is breathing cyan and then press ENTER

So back to square one I guess.

Hi @rosshill

Have you checked the router requirements?

The claiming step just associates you core ID (a hex number unique to each core) with your account on particle.io.

Flashing green means you are not online and your core is still searching for your wifi network. You need to get to breathing cyan to “claim”.

If you have a dual-band router (like an Apple Airport Extreme) try changing the SSID of the 5GHz band to be different from the 2.4GHz band’s SSID.


I’ll be sure to look into it tomorrow. Thanks for the help!