Unable to connect core to cloud

Hi,

I am stuck with this problem.

I am trying to claim a core and have not been able to do so. The process ends up getting stuck with cyan LED blinking. I can not get the particle identify to work either(gets stuck forever) so can not do that online.

Any help would be greatly appreciated.

Thanks
Sasi

Hey @sasi,

Has the core ever connected to the :cloud: before?

Do you have DFU-util or Particle-cli installed?

It might have been connected before in a different account.

I do have DFU-util and particle-cli installed.

Thanks
Sasi

Ok can you place the device in DFU-mode and run the command:

  • particle flash --usb cc3000 (blinking magenta and back to yellow`
  • particle flash --usb tinker
  • particle serial wifi

The core should eventually reach breathing cyan :slight_smile:

Thanks for your prompt response. It is still stuck while claiming. It is blinking cyan and does not move to the rainbow colors.

Thanks! Wait about 7 seconds while I save those credentials…

Serial said: Awesome. Now we’ll connect!

If you see a pulsing cyan light, your Spark Core
has connected to the Cloud and is ready to go!

If your LED flashes red or you encounter any other problems,
visit https://www.spark.io/support to debug.

Spark <3 you!

Done! Your device should now restart.
? Press ENTER when your core is breathing CYAN:
o Claiming the core to your account? Press ENTER when your core is breathing CYA. Claiming the core to your account

@sasi,

the core needs to be breathing cyan in order to claim it. Blinking cyan means it is unable to connect to the :cloud:.

Have you tried the steps i mentioned above?

Yes. I tired the steps. I meant breathing cyan earlier. I tried it on two cores and have the same problem. I see breathing cyan but can not get past this stage to where it shows the rainbow colors.

Do you see the cores listed using particle list?

Nope. I see a third one I had programmed successfully earlier.

Are the cores new? Place them in Listenin mode (blinking blue) and use the command particle serial identify to get the device id.

Ensure that the core is breathing cyan and use particle device add device_id to claim the core.

Hello,

same trouble here:

root@nef:~# particle flash --usb cc3000 
Found DFU device 2b04:d006
Apparently I didn't find a DFU device? util said  dfu-util 0.8

Found DFU: [2b04:d006] ver=0200, devnum=7, cfg=1, intf=0, alt=1, name="@DCT Flash   /0x00000000/01*016Kg", serial="00000000010C"
Found DFU: [2b04:d006] ver=0200, devnum=7, cfg=1, intf=0, alt=0, name="@Internal Flash   /0x08000000/03*016Ka,01*016Kg,01*064Kg,07*128Kg", serial="00000000010C"

checking file  /usr/local/lib/node_modules/particle-cli/binaries/cc3000-patch-programmer.bin
spawning dfu-util -d 2b04:d006 -a 0 -i 0 -s 0x080A0000:leave -D /usr/local/lib/node_modules/particle-cli/binaries/cc3000-patch-programmer.bin
dfu-util 0.8
[...]

dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!
Opening DFU capable USB device...
ID 2b04:d006
Run-time device DFU version 011a
Claiming USB DFU Interface...
Setting Alternate Setting #0 ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "Internal Flash   "
Downloading to address = 0x080a0000, size = 25068
Download    [=========================] 100%        25068 bytes
Download done.
File downloaded successfully
dfu-util: Error during download get_status
Error writing firmware...

This indicates that dfu-util transferred the data correctly. The last error is unfortunately a “known” error that happens every time you do get_status. You can safely ignore that part.

But the Error writing firmware is here all the time… and it goes blinking green afterward

eek! you shouldn’t be flashing cc3000 code to the photon! :fearful: How do we know it’s a photon?

Found DFU device 2b04:d006

In future we’ll print a message and not even attempt the DFU, but for the time being don’t do it!

Ok, maybe that’s a little overreaction. :slight_smile:

All said and done, it won’t do any harm - the photon won’t even attempt to run the code since it’s not a valid photon image, but doesn’t do any good either and will just be another potential source of confusion.

1 Like

Hi,
I have this problem.

>particle flash --usb cc3000
Found DFU device 1d50:607f
checking file  C:\Users\Gate\AppData\Roaming\npm\node_modules\particle-cli\binaries\cc3000-patch-programmer.bin
spawning dfu-util -d 1d50:607f -a 0 -i 0 -s 0x08005000:leave -D C:\Users\Gate\AppData\Roaming\npm\node_modules\particle-cli\binaries\cc3000-patch-programmer.bin
dfu-util 0.7

Copyright 2005-2008 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2012 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Filter on vendor = 0x1d50 product = 0x607f
Opening DFU capable USB device... Cannot open device

Error writing firmware...Cannot open device

>particle list
No devices found.

Help me

Are you on Windows?

Win 7

Can you run the CMD as adminstrator?

Yes, run by admin, UAC disabled

What happens with dfu-util -l?