Spark Core not connecting to the Cloud (Flashing Cyan)

I have been trying to get my Spark Core to connect to my new router but I have been having trouble. It continually flashes Cyan when I try to connect. This is the process:

  1. Factory Reset (Flashes Blue)
  2. Connecting to the Internet (Flashes Green)
  3. Connecting to the Cloud (Flashes Cyan)
  4. Connected to the Cloud (Breathing Cyan)

But when I upload some basic code (eg. Blinking LED) I get the following happening:

  1. Updates Firmware (Flashes Magenta)
  2. Connecting to the Internet (Flashes Green)
  3. Connecting to the Cloud (Flashes Cyan)

Then it repeats 2 and 3 over and over again. To eliminate all possibilities I tried it on a different network (my phone’s hot spot) but I got the same result. I have run the factory reset on the Spark Core and connected it via both my laptop and via the Spark App and I have gotten the same result.

I have had the core for almost 2 years with barely any problems with the hardware or the firmware and this is the first time this sort of problem has come up with me. I read about people that had similar problems, and it was concluded that there was something wrong with their Core ID. I eliminated that problem because I am able to successfully connect after running factory reset on the Core.

Any help would be greatly appreciated!

EDIT: Tried different code, same result :cry:

If things work after an FR and stop working with your code, my guess would be to have another look at your code.

How does the Core behave after an FR with subsequent

particle flash --usb tinker

@ScruffR

How would I upload that to my Core?

That’s the CLI command to be executed on your computer to upload Tinker to the Core via DFU :wink:

What’s DFU?

https://docs.particle.io/guide/getting-started/modes/core/#dfu-mode-device-firmware-upgrade-