Flash and Network issues with Spark Core (Kickstarter model)

Hi all

I have some problem with my core (kickstarter model):

  • LED flashing magenta after I do flash via particle.io/build take so long time
  • LED flashing red while connecting network
  • LED flashing cyan (forever) and cant connect to the network after i flash.

hope this video enough to explain my case.

I’ve tried a few advice the forum, like::

  • flashing cc3000 with particle flash --usb cc3000 until particle flash --usb tinker
  • patching cc3000 with this steps

but the core still can’t connect correctly:

I hope you guys can help me to find solutions or alternative to fix this problem. thank you.

Have you tried a factory reset already?

yes I’ve already did sir

So after a factory reset, it goes into blinking blue? The you reconfigure the credentials, and it goes into blinking green? Then it’ll go to breathing cyan?
Where exactly does it fail?

The problem is after I flash with other app, it won’t connect again to the network. Its always blink cyan.

So the factory reset does work, and gets it to run Tinker successfully?

yes sir, this is the condition after factory reset

Run Tinker no problem, but when I tried flash other apps, it wont connect at all. The condition is like my first post, long time flashing magenta, flashing red while connecting then flashing cyan rapidly.

Strange behavior to say the least. I’m not sure where the blinking red comes from, but it seems to make it to breathing cyan. Could you try flashing a really simple app, like the example “blink an LED”? That’ll rule out any issues with the user code.

video at the first post is condition after I flash with “Blink an LED” sir

Do you have the CLI installed?

yes i have sir

Can you place the device in DFU mode and do:

  • particle --factory tinker
  • particle --usb cc3000
  • particle --usb tinker

make sure all the commands are run in DFU mode

yes i have try that method, but not solving my problem.its still blinking red before it goes connected

Blinking red while running tinker?

no, but it happened before LED goes to breathing cyan. the LED state will be like this:
blinking blue -> solid blue -> flashing green -> high speed cyan -> blinking red -> breathing cyan. just like at the second video.

is this effect to my case?

If you see breathing cyan, the core is connected to the :cloud: so things are working.

Are you able to see that it is online?

Yes, but the problem is when i run/flash another apps, the core won’t connect to network. The core is only work after factory reset.

So the core is working fine and the actual issue is the code.

Can you post the code here?

sorry for late response. I got 18 hour offline time because newbie.

I just run “Blink an LED” from the example.