Core blinking green, cyan and yellow at boot

Hello, I have a Core in a personal project that was working perfectly for years, until today.
My network configuration changed, so I had to update my network settings. I tried with the usual particle serial wifi command and so on, but it gave me errors, so I decided to factory reset it, configure and flash it again with my firmware.

Then the problems started: I was basically never able to make it boot again with any custom firmware.
The pattern I noticed is the following:

  • If I do a hard reset, then I flash the bootloader binary I found on GitHub, and finally I configure the wifi, it correctly connects to the cloud.
  • If I later flash ANY other firmware, including tinker, no matter in which way (over cloud or through usb) it enters in this weird loop in which it restarts, starts blinking green, then cyan, then yellow, then it loops. Sometimes it only blinks green. I attach a video of what happens.

I did a lot of attempts in different ways, hard resets, flashing via usb, flashing via cloud, flashing using different versions of the firmware (I always used 0.7.0, but I tried with older ones with no success) and now I run out of ideas. I end up in this problem even at the end of particle doctor.

I don’t know if there is anything I can do to test if the hardware is still ok, or to perform some “deeper” reset. Do you have any tip?


The Core is no longer supported, however these instructions may help.

Since the Particle CLI does not support the Core anymore, you need to manually roll back to v2, see the instructions here.

Put the Core in DFU mode (blinking yellow)

particle flash --factory tinker

Wait till the Spark Core’s main RGB LED returns to flashing yellow

particle flash --usb cc3000

Wait till the Spark Core’s main RGB LED returns to flashing yellow

particle flash --usb tinker

If the device does not go into listening mode, hold down the MODE button until the LED blinks dark blue. Then set the Wi-Fi credentials:

particle serial wifi

I already tried that, but retried now…
So I started by doing a hard reset through Core buttons.

❱ particle --version

Put in DFU, then

❱ particle flash --factory tinker
Failed to flash tinker: EPERM: operation not permitted, scandir '/Users/alessandroorru/Library/Accounts'

❱ particle flash --usb --factory tinker
Error writing firmware: dfu-util: Warning: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release

dfu-util: Last page at 0x00038273 is not writeable

Anyway, moving forward:

❱ particle flash --usb cc3000
Flash success!

❱ particle flash --usb tinker
Flash success!

❱ particle serial wifi                                                                                                                                                                                                              12:47:51
? Should I scan for nearby Wi-Fi networks? Yes
... I did wifi setup ...
Done! Your device should now restart.

And it goes back to the state of the video :frowning:

It appears that the flash memory has failed on your Core; that’s what this message is indicating:

dfu-util: Last page at 0x00038273 is not writeable

Unfortunately there’s no way to fix that.

that was my fear :pensive:

thank you, I’ll get a newer device and do the rewiring on my board