Resurrecting a Core

I’m trying to resurrect an old particle core. The issue I’m having is that I can’t get the device to connect to wifi, and i can’t update the device via usb (from the CLI).

I’ve tried:

❯ particle doctor
The Device Doctor will put your device back into a healthy state
It will:
  - Upgrade system firmware
  - Flash the default Tinker app
  - Reset the device and server keys
  - Clear the Wi-Fi settings

The Doctor will operate on your Core connected over USB

PLEASE DISCONNECT ALL OTHER DEVICES BEFORE PROCEEDING

You'll be asked to put your device in DFU mode several times to reset different settings.

Flashing the Device Doctor app

This app allows changing more settings on your device

Put the device in DFU mode
Tap RESET/RST while holding MODE/SETUP until the device blinks yellow.
? Select Continue when ready Continue
The Doctor didn't complete successfully. Error writing firmware: Cannot read property 'filter' of undefined
> Please visit our community forums for help with this error:
https://community.particle.io/

I’ve also run setup, gotten all the way through connecting the device via wifi, but the device never connects:

> Setup is easy! Let's get started...
> It appears as though you are already logged in as xxx@gmail.com
? Would you like to use this account? Yes

! PROTIP: Hold the MODE/SETUP button on your device until it blinks blue!
! PROTIP: Please make sure you are connected to the internet. 

> I have detected a Core connected via USB.
? Would you like to continue with this one? Yes
? Should I scan for nearby Wi-Fi networks? Yes
? Select the Wi-Fi network with which you wish to connect your device: xxx
? Should I try to auto-detect the wireless security type? Yes
> Detected RSN(PSK/AES/AES) security
? Wi-Fi Password xxx
Done! Your device should now restart.
? Press ENTER when your core is breathing CYAN 

But the device never breathes CYAN.

I’ve also tried updating the device via DFU:

particle flash --usb xxx.bin
Error writing firmware: Cannot read property 'filter' of undefined

Any suggestions?

Thanks in advance

In order to use the Particle CLI with a Core you need to roll back to version 2, you can use the instructions here.

Put the Core in DFU mode by holding down both the RST and MODE buttons, releasing RST and continuing to hold down MODE until it blinks yellow and issue the commands below, in order.

After completing some of the steps the color may change to something else; if so note what color/pattern it is, then use the button combination to get back to blinking yellow. The core should be blinking yellow before each of the commands listed below is entered.

particle flash --usb --factory tinker
particle flash --usb deep_update_2014_06
particle flash --usb tinker
particle flash --usb cc3000
particle flash --usb tinker

Then put the Core in listening mode (blinking blue) if not already in that state by pressing and releasing RST. Then holding down MODE until it blinks dark blue. Then issue the command:

particle serial wifi

The normal sequence is white, blinking green, blinking cyan (light blue), fast blinking cyan, and finally breathing cyan. If you do not get to breathing cyan, please copy and paste the terminal output in your reply and let me know how far it did get.

1 Like

Thanks!

I finally figured out my issue - the core was trying to associate with my wireless network and was auto selecting 5GHz, but failing. I was able to force it to use 2.4GHz in my router and that seemed to resolve the connection issue.

Thanks again

2 Likes