Spark core - can't flash anything


I’ve been trying to get around this without luck.
I have a spark core that connects to the cloud without problem (most of the time breathing cyan, once in a while (after a long time) flashes cyan a little). I tried to flash the example blink-an-led.ino through the web-ide without luck: sometimes it goes magenta for a momento but the flash fails on the web.

Things I tried:

  • factory reset using the buttons
  • factory reset using the cli (particle flash --factory tinker fails thought: Last page at 0x000343af is not writeable) and I ended having to do a factory reset with the buttons again

I have the console too, didn’t try to flash through there yet because I’m just starting to play with this.

Any ideas?


My old Cores seem to require a periodic refresh of the TI CC3000 WiFi chip firmware–sometimes they just lose their minds and that is the only fix.

Photon is much more stable and pleasant to work with, which is basically why it was created.

particle flash --factory tinker
particle flash --usb cc3000
particle flash --usb tinker

You will have to re-enter all credentials.

As I said above, the first command fails with the following error: Last page at 0x000343af is not writeable

the others two work fine, but after that I can’t even setup the core. In order to “get it back”, I have to factory reset it using the buttons.


Okey, I tried to flash it through the CLI at first didn’t work but I put into DFU mode and resetted the keys (keys server & keys doctor ) and everything started to work. I can use the web-ide without problems now.

Really don’t know what happened here.