[SOLVED]Reflashing a corrupt Spark Core

Hello!

I have a older Spark Core 1.0 I got from JSConf 2014, and I recently have started trying to play around with it again. However, I’d been having trouble getting it to connect to the WiFi and as a last ditch effort attempted to re-flash the core via the CLI tool using the commands provided on the site

particle flash --factory tinker
particle flash --usb cc3000
particle flash --usb tinker

After that I’m no longer getting the initial cyan startup color, and it’s going straight to the flashing green. Pressing the reset button has no effect aside from killing power while the button is down. The mode button has no effect at all.

I suspect I screwed something up when I flashed the device. How can fix this?

That’s kinda what it’s supposed to do :wink:
When you say the mode button has no effect at all, what have you tried?
Could you try a factory reset to see if that helps?

1 Like

Is it really directly going into flashing green and no single white breathe? There should never have been cyan on startup.
But actually after a CC3000 update, your WiFi credentials should have been wiped, so you should end up in blinking blue after a reset (or have you entered your credentails and just not told us ;-)).

Have you checked the network restrictions for the Core (e.g. channel <= 11, only b,g networks, no n support, no 5GHz network)?


The behaviour I see when doing this

particle flash --factory tinker
particle flash --usb cc3000
particle flash --usb tinker

is

  • upload factory image - returns directly into DFU mode
  • upload CC3000 update - goes into blinking magenta - returns into DFU mode
  • upload Tinker app firmware - returns into Listening Mode (blinking blue)
  • particle serial wifi and credentials - returns into blinking green -> breathing cyan
  • after reset: single white breathe -> blinking green -> flashing cyan -> breathing cyan

If you like you can also try the “inofficial” particle flash --usb cc3000_1_14 instead of the official cc3000.

I’m red-green colorblind, so cyan = white, sorry. No white breathe at all for me, and it goes straight to the blinking green. The mode button doesn’t trigger the blinking blue at all, either. It only stays blinking green. However, I can’t flash because the device isn’t detected via usb at all now.

I’ll check the WiFi (and try the flash again) when I get home, but I think it should be fine because I’ve connected through it before.

The reason all of this came about was that I was having issues with serial timeouts and so I re-flashed thinking that it might solve the problem. Unfortunately, it resulted in the problem I’ve got now.

Okay, so I’m home and I’ve tried reflashing again, and all was successful!

Not sure what I did wrong when I first tried flashing, but everything seems to be fine now.

Thanks a bunch!

2 Likes