[SOLVED] Old Spark Core Connection Issue


I’ve an old spark core which I wasn’t using for a long time. Today I wanted to link it to my particle account with “Spark” Android app and saw that application couldn’t find the core. So then I followed these ([Spark core] Common issues) intructions:

  • particle flash --factory tinker
  • particle flash --usb cc3000 (will blink magenta and eventually revert to yellow)
  • particle flash --usb tinker
  • particle serial wifi

and successfully setup the wifi: “Done! Your device should now restart.”. The device is now breathing cyan but the spark app could not found it. What to do now?


First I’d do a:

particle list

and see if it’s already in your account.

If not, put the Core into Listening mode (blinking blue) by holding down MODE until it blinks blue. Then issue the CLI command:

particle identify

Save the Device ID; you’ll need it next.

Reset the Core and wait for it to breathe cyan again, then issue the command:

particle device add YOUR_DEVICE_ID

Thank you for your quick reply.

Here is the result

Was it breathing cyan when you did the particle device add? You could also try doing it from https://build.particle.io. Click on the Devices icon (circle with the lines, the target icon).

No, it’s not breathing.

I’ve tried the build site and the result is: “Could not claim device.” :frowning:

It needs to be breathing cyan before you can claim.

If it’s not breathing cyan, what colors/patterns is it showing now? The normal pattern is:

blinking green, blinking cyan, fast blinking cyan, breathing cyan

How far along does it go?

Thank you @rickkas7, after unplug and plug the device started the breathing cyan. After that I’ve successfully added via build site.