Spark core not recognised as USB device and flashes blue

I have been donated an older Spark Core v1.
When connecting it to my PC, I get a cyan breathing for 1 second, then solid blue for 1 second… flashing blue light…maybe twice a second.
My PC sees no USB device.

I’ve installed the Spark drivers.
The CLI

But nothing.

I’ve tried to hold down Reset + Mode… then release reset… holding the mode button down…device resets… but just returns to the blue flashing LED…

Has the device maybe given up on life?

With Cores it’s likely that it suffers from “amnesia”
The Core can be factory reset: press/hold SETUP, tap RESET, keep holding SETUP till you see rapid white blinking.

After that you can try revive it via CLI in DFU Mode (blinking yellow)

particle flash --factory tinker
particle flash --usb CC3000
particel flash --usb tinker

After that put the device in Listening Mode (blinking blue) and run

particle serial wifi

If it still can’t connect after that you can try refreshing the security keys via DFU Mode

particle keys doctor <yourDeviceID>
particle keys server

You should actually install the most current Particle drivers
https://binaries.particle.io/drivers/windows/particle_drivers.exe
Make sure to tick the “remove old drivers” option.

Thanks ScruffR.

I think the device is possibly faulty. I’ve tried the Hold Mode down… tap reset… and continue holding Mode until the flashing white. But, it never goes to flashing white. It goes back to flashing blue… and I’m still holding the mode button.

Sometimes, it seems to go into a rapidly flashing cyan… and sometimes, it goes into flashing green.

My technique:

Device plugged in and flashing blue.
HOld down Mode.
Press Reset.
Continue holding mode…
Device goes off, comes back and… and returns to flashing blue.
Release Mode.

Can you post a picture of that device?

Could it be that the MODE button isn’t actually working?

You might be right. I’m not sure if there’s a way I can check. When the device is on and flashing blue - should pressing mode do anything?

When I hold down reset and mode - a small blue light lights up at the top right of the board. Very faint. (Top right if looking at the board with the USB port at the top).

That’s an expected side effect of the button reset (pull-up resistor on the JTAG pin).

You could try with a DMM or oscilloscope.