My Spark core gets stuck on Magenta

I just recently got handed down my dads old spark core because i have just started getting into programming (i am in year 7) so i am extremely frustrated because i spent easily over a hour to install the particle.io software/command line thing to my mac. I have tried using different USB ports and i have tried the mobile app for the Spark core but no matter what i do or how i try i always end up in the same fate stuck on a solid magenta light

If it’s really a Spark Core then you should be in luck, since this still has a proper Factory Reset.

Perform one or two of them, to make sure your device is nice and clean.

And then try to find out, if your Dad still got this Core claimed to his accound. If so, he might either hand you the account (:sunglasses:) or unclaim the device, so that you can claim it.

If that is sorted, try setting up your device by use of CLI (which I understand you got running already).
Normally after the Factory Reset your Core should already come back in Listening Mode (blinking blue).
When your Core is in LM, try particle setup.

In addition to trying out different USBs, have you also tried different USB cables? They sometimes mess things up too.


If this still doesn’t change a thing, can you post the output of CLI (particle setup) here?
And also try to search this forum for core solid magenta and have a browse.

hey @ScruffR i am using the same cable i use to charge my HTC one because i had a similar issue with the cable with that

so i just went and attempted a factory reset only whenever it gets up to claiming the core it breathes cyan then goes solid purple/magenta

Can you put your Core into DFU mode (blinking yellow)?

Have you done a forum search as suggested?

i have done a forum search and nothing has worked and i can get it into DFU mode @ScruffR

so i managed to figure out the credentials for my dads account and now it is going rainbow

@ScruffR only now it gets stuck on the rainbow step and becomes magenta and sets there

Hi.
Same here.
Many factory resets, many listening mode, no node.js installable on my PC,
after every reset my core connects, and then gets stuck on magenta.
A couple of times it stuck on rainbow after naming it -phone app crashing-, but on a reset the solid magenta came again.

I can “see” it on my COM3, but I can’t seem to “talk” to it, even with driver installed, with putty.
DFU-util does not recognize “spark” as a valid command, even in flashing yellow.

Thank you in advance.

What do you mean with that? It’s not dfu-util that would need to recognice spark (or rather particle now).

Sorry, missed the no in this sentence


If node.js was available:

To install particle-cli (or the particle “command”), you’d usually do

npm install -g particle-cli

If you already have CLI installed, make sure to update via

npm update -g particle-cli

After this you should be able to type particle on your console and should get this response

Welcome to the Particle Command line utility!
Version 1.8.16
https://github.com/spark/particle-cli

Usage: particle <command_name> <arguments>
Common Commands:

    setup, list, call, get, device, identify, flash, subscribe
    compile, monitor, login, logout, help

Less Common Commands:
    token, cloud, config, function, keys, serial, udp, update
    variable, webhook, wireless

For more information Run: particle help <command_name>

Sorry. I see now I mixed the Spark-cli command with DFU ones.
I have just flashed the new core thinker, and running -I think- the major update… my core has been slow breathing cyan as I write for some minutes (edit: and does not appear as connected in the IDE, but it appears)
I hope it is not a new kind of stuck :smiley:

sorry again for the wrong info (and my bad english)

It’s not to uncommon that Web IDE gets confused which device is online/offline

You can also try these
https://dashboard.particle.io/user/devices
http://suda.github.io/particle-web-interface/
http://jordymoors.nl/interface/

1 Like

Thank you :smile:
Now it is solved, I think.

May it be my fault, keeping the phone app AND the IDE online?

This should pose no problem.

You should make sure that the Spark Core is not claimed to your father, you could try to log in via build.particle.io to check if the device is already claimed, if it is, Problem solved. If not, i’m afraid i can’t help you out

Been there, but thanks for any thought.

i unclaimed it and reclaimed it as my own