Can't claim cores. Getting solid magenta

Both of my cores cannot be claimed via the app. Both have the same light sequence.
Blinking blue: Listening for Wi-Fi credentials
Solid blue
Blinking green
Blinking cyan
Breathing cyan for about 2 seconds
Solid Magenta

The app will then eventually tell me my core cannot be claimed.

I tried through the usb but I am just getting back into this and about as novice as one can get. Everytime I fix an error given by Command Prompt a new one pops up and it’s getting frustrating to get Spark Cli installed. I also tried claiming it through the Spark Build with the core’s id…to no avail. Many resets later I am still nowhere.

Is Spark CLI my only option here?

Have you tried factory resetting the cores? i had to reset mine twice in a row when i had this same issue

1 Like

I have done multiple resets but I may not have done them in a row. I will give that a try.

Tried multiple factory resets in a row. Same color sequence and app can’t find any cores.

Same here, i have exact symptoms.

Have you tried these instructions to get setup over USB?

Some Android phones don’t work with the app–try USB.

Would love a video from @gemby or @Skaliwagg for a quick visual inspection of what’s going on if possible! :smile:

1 Like

I have tried however I can’t get the CLI installed. I think it has something to do with visual studio but I’m not sure. I tried grabbing the ID and claiming through the Spark Build but that didn’t even do anything, the app will at least trigger the spark core but still won’t find a core.

You don’t technically need the Spark CLI; you can use a terminal emulator like PuTTY as the instructions say. You can claim the core in the webIDE with the number core ID from the terminal program.

@kennethlimcp had a good idea–a video would help us figure out what is wrong.

here’s a quick video

Yep, I tried that claiming in the Spark Build.


I’m assuming you powered up the core, it entered breathing cyan and immediately become solid magenta?

You did not download any program or something during the process right?

On startup it will go into listening mode. When I try to to connect through the app on my phone it will go into the sequence I posted. I don’t recall it ever blinked magenta for an update. I can’t count all the resets I’ve done.

Yes, this is exactly why i am getting

I am able to claim core without problems, but in first minute or two after power up. It is visible trough clould too, but after minute or so after turning solid magenta, it goes offline.

  • factory reset, and reconnecting to wireless via usb / serial
  • deleting and reclaiming core again
  • different cable and power supply
  • different wireless network

I tried to program it, but it seems that “online window” is to short, so i am unable to do that trough cloud.


During the 1-2 minutes when the core gets online, did you perform any task? Like flash firmware etc…

I will be happy to help you fix this but it will take some effort on your part. Otherwise, we can arrange for an exchange. :smile:

My guess is that the core default firmware and the factory reset firmware is giving us a headache since factory reset did not helped. Or the CC3000 needs a patch!

A combination of these will solve the issue and i’m confident it will work :wink:

Another way to get some idea is to grab an access-token from the Web IDE and open this url:

You will see some output when the core gets online. This should give us some idea what’s going on as well as the CC3000 patch version!

Yes, when is online it says:

curl ''
  "id": "xxxxxxxxxx",
  "name": "Sparky",
  "connected": true,
  "variables": [],
  "functions": [],
  "cc3000_patch_version": "1.28"

After minute or so it says:

curl ''
  "id": "xxxxxxxxx",
  "name": "Sparky",
  "connected": false,
  "variables": null,
  "functions": null,
  "cc3000_patch_version": "1.28"

I removed real device ID, and access_token

As i said, it appears online for minute or so regardless it went to “solid magenta” state, and then goes offline, without any further notification.

1 Like

Useful info @gemby!

I bet you are a long-time supporter of Spark since your CC3000 version is the older one.

Are you on windows? I can guide you along to perform a patch and it should be working well :smile:

Yep, this is kickstarter edition, but it was almost unused since now, no, it is OSX, i already installed spark-cli and dfu-util ( ) , and will try to update it later today.

So, if i got it correctly, i should put it in DFU mode

spark flash --usb cc3000
spark flash --usb cc3000

and then make a deep update

spark flash --usb deep_update_2014_06

Is it correct?

1 Like