Issues with connecting, claiming, finding sparkcore

So I have been at this for a few hours now going through the guides and trying all the different methods of connecting, claiming, and finding the sparkcore.

I started by resetting to factory default tried the android spark core app on sprint lg g2 on my home network. it got the sparkcore to breath cyan but then said no cores found. I followed similar posts and nothing worked for me.

I tried connecting over usb on windows, install the driver; however, windows is not seeing the device in device manager. I tried just going through com port numbers hoping to find it and it still could not connect via putty.

I do not know how to try and resolve this. I have factory reset it multiple times, tried having it forget connecting/creds.

@abarkle1, is it a new core that you are attempting to claim?

No, it is used. We unclaimed it from a previous and then my buddy just unclaimed it a few hours ago.

Sounds good! Do you have the core id? You can claim it under your account once the core is breathing cyan via the Web IDE.

If you need the core id, place the core in listening mode (blinking blue) and use a Serial terminal or Spark-cli to retrieve it :wink:

I used the spark-cli method (because I cannot get it to connect via serial as I stated in initial post) and it just said no cores found. After I tried both methods, I can no longer get it to breathing cyan color anymore. I reset it back to factory default again and tried using the same smart config the allowed for breathing cyan (but did not allow for claiming and said no cores found) and it is no longer working.


1.) Can you place the core in DFU mode(blinking yellow) and run spark flash --usb cc3000?

2.) After the core blinks magenta and reverts to blinking yellow, run spark flash --usb tinker

3.) Next, the core should blink blue and type spark setup wifi

You should now be able to send in wifi credentials

I tried all three to no avail. The first two said “Apparently I didn’t find a DFU device? util said Error writing firmware… no dfu device found.”

The third said “I didn’t find any cores available via serial”

Edit: I did make sure it was in DFU first

Okay I got it back to breathing cyan and then inputed the sparcore id into the Web IDE and now it is claimed. I do not know what changed but thank you.

1 Like