No Cores Found Over Wifi or USB

I’m having issues claiming my core via Android app and USB. I am able to connect my core to my WiFi network and achieve the breathing cyan LED, even after a factory reset, but I continually get the No Cores Found screen. I tried going over to USB connection and I can’t get putty to get the Spark Core ID. I got the serial window to pop up and when I try to send over the ‘i’ command, I get the same thing over and over :

echo:Unknown command: “i”

I have connected to it in the past, is it possible that the Spark Core has been claimed by a different username and now refuses to be claimed again? I tried factory reset but maybe the Spark Core ID remained in my old account? Any help would be appreciated.

For security reasons, a core that is claimed will remained tagged to the account unless you deliberately un-claim it.

You can login to the Web IDE and under ‘cores’ tab, un-claim the core :wink:


I’ve tried that, but the only email I have attached to this website doesn’t have any cores claimed. I only have three email addresses to my name and I tried to reset a password on the other two to no avail. So I guess my only option is to try to reclaim this core.

I tried connecting to the core via USB through the Spark CLI and it can’t find the spark. I have it in the blinking blue mode, can’t find it. I put it in DFU mode and even installed the DFU-util and it cant find the core to apply the CC3000 patch, and like I said before I can’t even connect to it via putty. I’m starting to think I have a bad board that can’t connect via serial.

I don’t understand what you are trying to do?

You will not be able unclaim via spark cli without the right account.

If you have the core id and the email address you think you tagged the core to, drop HQ an email at to unclaim it.

For dfu-util in windows, you need to change the driver for it to be detected. Otherwise, you will not be able to flash firmware. :slight_smile:

1 Like

If you are on Windows (you need the windows driver), you should follow this guide:

See references to Putty at the very bottom of that first post.

If you are on a Mac, try the official Docs suggestion of CoolTerm:

1 Like

I was able to resolve the issue, although it looks like I won’t be able to add much value to the thread.

I was able to get my PC to find the device via USB and once found, I used putty to grab the ID. With the ID, I was able to go to the web IDE and claim it under my account. I’m not sure what the USB issue was. I’m guessing it was never previously claimed, it just appeared unresponsive to my computer since it never mounted. Thank you guys for your help.

Edit: I wasn’t able to use the spark CLI to identify my board, so I followed the USB driver instructions above and was able to fix it. Interestingly, my device manager was using a driver for by board. PJRC is the manufacturer of the Teensy which I own. I’m not sure if my computer decided to use the PJRC driver, or how it got associated to my Spark Core, but when I uninstalled it and reinstalled the spark driver I was able to run the spark identify command via CLI. Unfortunately, I still can’t do any DFU related tasks via CLI. I’m guessing my DFU-util is screwed up. I don’t know why, it is pretty straight forward.

1 Like