"Could not claim core"

Hi,
I recently received a set of cores from the Kickstarter campaign but have tried and failed to set them all up. The LED lights confirm successful connection to the Internet (slow “breathing” cyan), but the Android app refuses to recognise their existence, saying “no cores found”. I’ve connected directly to a Windows 8 PC instead, gained the Core ID via PuTTY but when I enter this in the Build website, it just returns with “Could not claim core”.

Any suggestions on what I’m doing wrong?

Thanks,
Paul

1 Like

@Simmo Hmm, strange, I haven’t heard of a core that is breathing cyan/connected not be able to get claimed via the IDE yet. Could you email me your core ID(s) and I can take a closer look? (my email is joe at spark dot io)

I just wanted to chime in here as well in case this isn’t resolved yet. You can also email me at david@spark.io with those ids and I can check the logs and see what’s up. :smile:

Same thing is happening to me. I emailed you both with my core id.

1 Like

Hey Guys,

Thanks to @julio and Benjamin, we’ve identified a problem on the build site right now when manually claiming cores using Chrome. I’ve posted the incident on our status page here: http://status.spark.io/, and we’ll keep you posted. In the meantime you can still claim cores using alternate browsers like Firefox, and using the mobile apps.

Thanks,
David

Same deal with my two Spark cores that arrived just today… Android app seems to work up to “breathing cyan led” but the app after a rather long time, 1 minute or so " NO Cores found…try again , which I did on both units with no results other than above… Sorry, I down loaded PuTTY , but don’t have a clue on using it . I connect the core with a USB cable to a windows 8 machine (after holding down the mode button for 10 seconds) and Windows sees it but says no driver installed…so no serial port has been assigned?

What do I do???

I have exactly the same problem as sierrasmith71!

Hi All,
To use PuTTY to connect to the core on Windows you’ll first need to install the driver (see link from this page: http://docs.spark.io/#/connect/connecting-your-core-connect-over-usb). On Windows 8 it’s a little more difficult since you’ll need to provide special permissions to install the unsigned driver (see: http://answers.microsoft.com/en-us/windows/forum/windows_8-hardware/how-to-install-a-driver-that-does-not-contain/7c3f299b-3483-4c96-8c44-87c7451af222)

So far the process to get the cores up and running has been very haphazard. For two of my devices, this is the only way I could get them to work:

  • Reset into listening mode (hold down button on core for 10 seconds)
  • Unplug and reconnect USB cable to PC
  • Use device manager on PC to work out which COM port it was connected
    to (changes between COM3, COM4 and COM5)
  • Use PuTTy to gain the Core ID
  • Disconnect USB and reconnect again (no idea why, but it won’t work without this)
  • Use the Android Spark app to attempt to find the core - this gets it working on Wifi but still fails to claim the core. I have to do this as it won’t connect to Wifi if I use the “w” option via PuTTY - again, I have no idea why.
  • Log into the build website to claim the core
  • Log out of the Android app, then back in again - this now has the core listed, allowing me to use the Tinker app

Not ideal… Any ideas on a better way to get things working!?

Thanks,
Paul

1 Like

Thanks @Simmo for providing such a detailed account of how to get around this issue, this kind of information is very useful in developer diagnosing+fixing as well as a workaround for folks until the bug is resolved. This is on the top of our list of things to fix, either I or @zachary will post here when we’ve pushed a fix, hopefully in the next day or two.

Thanks @Simmo the instructions worked for me. Plus I had to use FireFox on Spark web IDE.

I wasn’t able to register it on IE, getting no indication. I had added the core but would get 403 errors when trying to flash. On Firefox I got errors registering it until I cycled the USB power, then it worked. I flashed the blinker app from the web IDE OK.

Then I started the iOS app and it went right into tinker. This broke the flash on the web IDE and gave 400 errors. Once I logged out of the Spark iOS app, and did a hard refresh of the webIDE, I could reflash again.

Still not 100% working on Tinker, but webIDE is working for me!

1 Like

I did something similiar to @Simmo as I have the same problem, but I still recieved “Could not claim core”. Tried using Chrome, Firefox and even IE.

The core kept flashing blue, and my android phone could never find the core. It will flash green if I connect it to the computer, but if I hold down the mode button for 3 sec it will flash blue untill I reconnect it to the computer.

Emailed @Dave the core ID

@brokn9 @mineson @Simmo @sierrasmith71 @julio Just wanted to drop a line to mention that we believe we have resolved the issue that prevented one from claiming a core in the IDE. Please let us know if you see any other issues.

Thanks for reporting this, conjuring up and sharing workarounds, and your patience while we worked out a solution, must appreciated!

I seem to have a similar problem. I cannot get the core to connect via the android-app so I used the serial over usb-variant instead (“w”). I am getting a breathing cyan light and I have successfully retrieved the core id using “i”.
However, when I go into the Web IDE to claim the core, I just get the “could not claim core” error message.
I have tried in both firefox and chrome.

2 Likes

If you fail to claim a core, even after making sure that you typed it in correctly, you can email the Core ID to hello@spark.io and we’ll add the ID to the database manually.

Thanks!

Also keep in mind that the Core must be online for you to claim it (breathing cyan)

Thanks, I’ll try that :slight_smile:

Yea I am having the same exact problem. I connect the core to the internet with the App, but when I sign in to code it with the web IDE, it does not see my core anymore.

Now the App does not even want to connect to the Core. The light keeps searching (green blink) but times out.

Hi @kevin_1,

If you’ve already previously claimed your core, it wouldn’t just drop out of your list of cores, I would double check and make sure you’re logged into the correct account. :slight_smile:

If you flashed some code and now your core isn’t connecting, maybe try a factory reset: http://docs.spark.io/#/troubleshooting/troubleshoot-by-color-flashing-green

Or you can email me (david@spark.io) from the account you used to claim your core, with your core id, and I can check and see if there was a typo initially.

Thanks,
David

I did the factory reset and the core dropped from the App and now just blinks blue. It was controlling another chip and now it does not recognize anything.

I emailed hello@spark.io my ID.

Hi @kevin_1,

When you do a factory reset, you’re overwriting your loaded program with the version of Tinker that was flashed onto the core at the factory.

I’ll continue support via the hello account.

Thanks,
David