Failed to claim core, server said [ 'Device is not connected' ]

After a long evening, I still don’t have a connected claimed core.

The core is connected to wifi and is blinking green (not really breathing, more hyperventilating, and looks green to me, not cyan).

I have my core Id, via spark CLI, and tried using spark setup to claim it, but keep getting the same error stated in the subject.

Going to and Cores shows no core claimed. Clicking Add New Core and pasting in my ID yields “Could not claim core”

I carefully typed and checked the ID several times, so I don’t think that’s the culprit. I saw the other thread where 10min did the trick, but I don’t have his luck. Any ideas?

Since it is not breathing cyan, it means that connection to the cloud is nit happening.

Can you put your code in DFU mode (blinking yellow) and use spark flash --usb cc3000

Hi @jkucera,

Thanks for posting! I’m not seeing that core id as having connected successfully, so I think there is either an issue with it getting online, or an issue with the server key on the core. Any chance you could post a video of the lights on the core?


Thanks for the fast replies! I was going to wait to reply until tonight when I could test more, but it sounds like wifi connection is the issue. I didn’t find this article until too late, but found it very helpful to reassure me that I’m not color blind :slight_smile:

I will try the steps here tonight and will post an update with my progress:

I’m using an AirPort Extreme which does support b/g so that shouldn’t be the problem. While I was 20’ away, I tested earlier from 1’ away as well.

Only other guess I had was that there’s a space in my SSID (speed central), but the credentials seemed to save fine, so that probably isn’t the issue either.

After trying a few other things, the factory reset finally did the trick and I was able to connect via mobile app.

Thanks for the replies Dave & Kenneth!


I am Experiencing the same problem,
what i thing is that a key sync (server-core) problem exists.
BUT there is no way found to solve it.
Spark-cli is more flexible but does not giving the solution to me.
I did all procedure to sync keys but nothing happend.
Here is the result after , spark cloud claim XXXXXXXXXXXXXXXXXXXXXXX, command.

Failed to claim core, server said  [ ‘Device is not connected’ ]
Potentially unhandled rejection [1] {“ok”:false,“errors”:[“Device is not connected”]} (WARNING: non-Error used)

Feeling stupid, but hopping that something else is going on

Do you mean that your core is blinking yellow/red?

You can use spark keys doctor core_id with your core in DFU mode and see if it helps :slight_smile:

1 Like

I have the same problem. I have cyan light on my spark core, pass without errors spark keys doctor my_core_id and i still cannot claim my spark core.

Can anyone help me?

Btw, very important think is that you MUST copy dfu-util files to openssl bin folder and run spark keys doctor my_core_id from openssl bin folder, in windows. Otherwise command should not work, you’ll have following error
Apparently I didn’t find a DFU device? util said
Make sure your core is in DFU mode (blinking yellow), and that your computer is online.
Error - no dfu device found.

You probably need to make sure you have the dfu driver installed, see here: