Fast flashing white, then solid blue, then repeats

I purchased two spark cores, one works fine out of the box… it was the second of the two I tried.

The first however exhibits a strange behavior, also out of the box, that I haven’t been able to find mention of in these forums anywhere. It fast flashes white for about one second, then changes to solid blue for about half a second. It repeats that cycle endlessly.

I’ve tried factory resetting, but executing that, memory clear or anything else doesn’t seem to work. In fact, the LEDs go off, except the little blue led that comes on when you reset.

I’m wondering if there was some issue with a factory reset failing before it arrived. Ideas?

Hi @George,

Were you able to ever put the core into listening mode or configure wifi on this core, or is it always stuck in this mode?

Hello @George
Also, how are you powering the Core? Sometimes when the supply current is in sufficient, the Core may behave erratically.

1 Like

I’m powering it via usb connected to my laptop. The same connection and cable worked with my other Spark Core. I can try something else if you suggest.

I wasn’t able to get it into any other mode at all. This is all that it does other than reset and continue this cycle.

Hi @George,

The light pattern you’re describing makes me think either the firmware on that core needs to be re-flashed, or the chip itself might be bad. Would you be willing to try re-flashing the firmware over usb?

if you install dfu:

and grab the compiled firmware from here:

Connect your core in dfu mode. Hold down both buttons and release reset. Release the mode button once the core starts flashing yellow.

Run the following command using dfu-util:

dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -D core-firmware.bin

(might need to use sudo, or run as an administrator)

1 Like

Thanks Dave! Trying it now. Will let you know what happens.

I copy pasted your command running as root here’s the output:
:# invalid dfuse address: 0x08005000:leave

Hi @George,

I think that’s usually a sign that your copy of dfu-util is old? The current version is 0.7. You can also remove the “:leave” part and add “–reset” if you don’t want to upgrade (but you probably should :slight_smile: )

Ok @Dave , I’ve downloaded and compiled from source dfu-util. I’ve got 0.7 confirmed when I run the command. Unfortunately it’s now reporting that No DFU capable USB device found.

and dfu-util -l doesn’t show any devices either.

I’ve got the core connected via USB to the spark USB cable it shipped with.

For S&Gs I put the working core into DFU mode, and it shows up when I try dfu-util -l. Also… a difference, in DFU mode, on the working core, it flashes yellow maybe 10x per second, where as the other core flashes only about once per second for about 500 milliseconds.

Don’t know if that helps out with context a bit better. I’m glad I have two here for comparison.

Hi @George,

Hmm… That’s weird. You might need to do “sudo dfu-util”, if you were able to get your core to appear once in dfu-mode, I suspect it should work again. I’d be curious to see if it’s showing up as 1d50:607f, or if it’s showing up as another vendor id.

If we really can’t get dfu working and you don’t have a programmer shield handy I’m guessing maybe our best bet is doing an exchange. It’s possible your other core has a bad copy of the bootloader or a defect. Can you email us at and we can coordinate from there. I think we’ll be out of the office tomorrow (New Years Day), but we’ll be back in force Thursday. Unfortunately there are only a very small number of replacement cores, so it might take us a while to get a new one out to you. We’ve also got another run of manufacturing starting in about a week or so. (I think)


1 Like

@Dave, I tried both using sudo and as my own user, with the same results. The core that I was able to get to appear was the second one I have that’s working fine.

I think your theories about a bad bootloader or some kind of defect sound probable. I’ll fire off an email to you and we can work out the exchange. As I’ve got one working core to play with (and I have been), I’m not worried about a longer turnaround.

Thank you and @mohit for your help with this, and on New Year’s Eve no less. Wonderful support gentlemen, seriously.