My core is connected but the Android app can't find it

So the core LED is “breathing cyan” quite happily, but I can’t get the Android app to find it.

I do not have a password on my wifi I should but that’s another issue I just use MAC address filtering. I found the MAC for my core and added it to the whitelist and it’s fine.

But I enter the SSID and leave the password field blank and press the enter key on the phone since the Connect button is grayed out unless you enter a password.

Which leaves me wondering if the app requires a password protected wifi?

I think we have a bug right now on the mobile apps that doesn’t handle empty passwords gracefully. If you grab your core id over serial, you can claim it manually using the build site.

There are some notes here on getting your core id, but please let me know if something is missing:

So I haven’t had any luck with the USB. I used F8 to get Windows 7 to allow unsigned drivers. But when I put the sparkcore into flashing yellow light mode it shows up as CORE DFU but won’t install the driver. So I figured what the hell, opened the driver inf file and noticed the device id said


but on the properties page of the CORE DFU device it gave it as


So I changed it, it installed ok and the device is now using COM4 but the it gives the error “Device cannot start”

On putty it says COM4 is disconnected.


I just reconfigured my Wifi network with a password.

I finally got the core to listening mode by clearing the memory and figured out the driver situation. Used the original one when it wasn’t in DFU mode. Sent the packet with the app, the core appeared to get the config info and went to breathing cyanI couldn’t quite tell. But the Android app still wouldn’t find the core.

I tried putty on COM5 and it says “can’t open the serial port”

Edit. Success it finally connected on COM5 so I could get my ID

1 Like

Nice! Glad you got your credentials going over serial! For other people finding this thread, it sounds like make sure your core is in listening mode when trying to configure over serial:

Thanks. Now to figure out all the API stuff haha.

I will say for anyone else who reads this post that I wasn’t able to get the Android app (on a Nexus 5) to connect directly to the core but it did send the packets to program it successfully. Even when I reverted back to my old wireless settings where there’s no password.

1 Like

Hey guys,

I am having this problem as well. I went to set up the Spark Core with the Android app (on my Galaxy S4), and it took a long time while the button was red. Eventually it reported that no Spark Core could be found, and an additional (os-level) dialogue opened up saying that Spark could not be conctacted and to check my internet connection.

Meanwhile, the Core itself went from slow blue blinking to quick green blinking, back to slow blue, and then quick green again, and then after a while it went to slow cyan breathing. From what I’ve read, that means it’s connected. Indeed, I can see the core in my router’s web interface and I can even ping it just fine.

I’ve gone through the setup process with the smartphone app several times, having reset the chip’s memory via the instructions and rebooted (I did not try resetting the firmware to factory settings).

I went ahead and grabbed the serial number off the core via serial/USB and plugged it into the web interface to claim it. I’m bummed, though, because I can’t use the Tinker app on my phone… it looks so cool!

Here are some specs:

  • Core with chip antenna, CC3000
  • Android 4.2.2 / Galaxy S4
  • Netgear WNR2000v2, running DD-WRTv2 with WEP2 security

I’d love to know I did something boneheaded, or I’m glad to offer any assistance with debugging.


Wait, now I went through the app to connect again (for the first time since I claimed the Core ID manually), and this time there was a button that said “Continue Anyway” at the end after it failed to find the Core. So I tapped it, and now it looks like things are good with the Tinker app. It must understand that I grabbed that Core manually. So yeah, nice work! I’m gonna rock some internet-powered LEDs now.


I had the same problem, the core was connected to wifi but the Android app couldn’t find it. I tried resetting the core several times, didn’t help.

Tried iOS app instead, worked without any issues…

Hi @Markus,

Thank you for posting, can I ask which android phone / android version you’re using?


Nexus 5 with Android 4.4.2 and ART enabled. The iPad is running the latest iOS 7.

There’s a known issue with Nexus 5; Smart Config simply doesn’t work on the device. We’re working with Texas Instruments on a solution.

I suppose we should document that somewhere…


That explains the original problem. I have a Nexus 5 as well.

Hello every one . do you know about How to disconnect ti devices list on click button . if know any one please about this so please share code with me . thanks