Cannot access core over USB [Solved]

Hey all,

I have 3 cores, 2 are connected and running great, 1 just will not connect. While I have never gotten the mobile app to work after what must be 50 or so tries over the past few months with all cores (Android app running on HTC One, Wifi is pretty basic with WPA2), the USB / Putty combo worked great for the first 2 cores. The third will not get recognized by my machine.

I tried multiple laptops (all windows based) and it cannot be found or opened as a COM port anywhere. I’ve done many factory resets, reboots of core and machine, try to access the core via Cygwin, etc. And here is what might be the kicker: I did get the third core connected once, then after having some trouble flashing code from spark.io/build I did a factory reset and that’s when I stopped being able to communicate with it over USB.

What am I missing?

-paul

One thing factory reset usually does (at least with my Cores) is that it also wipes the deep update, leaving the Core incapable to connect to WPA2.
So you’ll need to reflash this to get this Core connected to your WiFi.

Now some questions

  • Have you got Spark CLI and dfu-util installed on your machine?
  • Can you put your Core into DFU mode and/or listening mode?
  • Does dfu-util recognize your Core?
  • Have you got any color codes to help narrow down the causes?
  • Can you confirm that you haven’t got a bad USB connector on your Core?
  • Could you get the Android app to work with your two good Cores?

@ScruffR, the deep update is run once on the cc3000 and not affected by factory reset! The credentials on the cc3000 are usually wiped and the factory firmware may not be the latest since it is not updated unless you use Spark CLI. This is the problematic part. One easy way to update a Core’s factory reset over USB is with Spark CLI using spark flash --factory tinker. :smile:

1 Like

Thanks for the quick replies!

Answers (in order)

  • I did have Spark CLI, but not dfu-util. I just got dfu-util and it notes that "Cannot open DFU device : (with actual identifiers on there)
  • It is in listening mode when a boot it, and I can get it into DFU mode
  • dfu-util can’t open the device
  • nope, just listening mode on boot
  • Not sure what to look for as the connector looks solid, but I’ve tried multiple cables to no avail
  • The Android app never worked with any of the 3 cores

@peekay123, then I’m rather puzzled with the behaviour of my own Cores.

Whenever I perform a factory reset by means of the MODE button, than I seem to loose the deep update (or something I seem to confuse with the deep update), since when then trying to then enter my credentials via USB I never get the choice of WiFi security settings, but after performing deep_update, voilà I can choose (0) unsecured / (1) WEP/ (2) WAP / (3) WAP2.

How does this line up with your insight?
I’m really puzzled now :stuck_out_tongue_winking_eye:

The deep update updates the code on the CC3000 (the actual CC3000 firmware).

When you do a factory reset you are replacing whatever firmware is on your Spark Core with a, most likely old, version of Tinker stored in flash. That version of tinker (actually the firmware that Tinker was built with) is what you are interacting with when you go to put your core in listen mode after a factory reset.

Try this. Do a full firmware upgrade (http://support.spark.io/hc/en-us/articles/203108844-Perform-a-Full-Firmware-Upgrade) and then do a factory reset. You should see the (0) unsecured / (1) WEP/ (2) WAP / (3) WAP2. instead of the old version.

@pcaponetti When you put your core into DFU mode what do you see in Device Manager?

1 Like

In listening and DFU mode I see nothing in device manager. No change seems to happen when plugging and unplugging the spark core from my machine.

Thanks @harrisonhjones for the clarification - so I’ve always used the term “deep update” the wrong way :blush:

So after this I’m a bit reluctant to give advice, which I might get wrong again :wink:
But defying the embarrassment I’d ask @pcaponetti: I guess you’re on Windows, so have you got Zatig installed and selected the correct driver?

See here

1 Like

I’ve tried, but Zatig doesn’t even see the core when in listening or DFU mode :confused:

@pcaponetti, I HAVE to say it… Have you tried a different USB cable? :scream:

2 Likes

Saw that one coming :wink:

Yup I’ve tried a few up until this point (including the supplied cord)…

But alas, just tried a cord from my phone charger and now it works… Love that my first post on the forum ends in a face-palm.

Thanks @ScruffR @peekay123 and @harrisonhjones for the help!

4 Likes

As it turns out, sometimes even already tested options have to be checked frequently.

Maybe it was a joint problem and something done in between the “two” cable tests did contribute to the solution.

@pcaponetti, can we mark this solved then?