Core dies while trying to setup via usb

I’m trying to get my core setup. In its life its only ever connected once to any network. Now it always times out on the app. I read about the spark-cli and figured I’d give it a try. Howerver, as soon as it gets to the wifi handshake part. My core immediately dies. Whole processing has been frustrating. Its been a cycle of try for an hour or two with no results after reading the posts and everything I can. Get frustrated and focus on other stuff for a while. Give it another shot with the same results. Just sort of at my wits end at this point.

What do you mean by “die”?

What’s the colour on the RGB led?

Did you try performing a factory reset?

Performed 3 factory resets. By die. I mean it powers off. No lights. Can’t connect via any method list on the site. Beyond frustrated now and just depressed about not being able to use it.

What was the behavior of the core when you first take it out of the box and power up?

Was there light?

During factory reset, you should see blinking yellow followed by flashing white.

We can always have it replaced if the hardware is faulty. :slight_smile:

I was kickstarter backer. I’ve never really got it working beyond the one time I was able to claim it. I just don’t have a lot of time to invest in debugging something like this. So its only been in 30-60 minute chunks in between or to take a break from other projects. Got renewed interest in it because I have a project I want to build, but no luck. All the correct lights came on during factory reset.

Ok cool. The kickstarter core might require some simple patching to make it more stable etc.

1.) After the factory reset, is it blinking blue?

2.) If it’s not blinking blue, it the D7 led dimly lit?

All it does is blink blue

Ah nice. That’s how it’s supposed to be after a factory reset.

The next step is to send the Wifi credentials via the Spark App.

Try that! :smiley:

As had stated above. I have tried all methods to connect to my spark. I have probably wasted 20+hrs that I could have spent consulting or doing other work. So far my opportunity cost lost setting this at least 20x the cost. I’m about to just give up and toss it in the trash to be honest.

To be more clear:
App: times out
Serial: Can’t find it
Spark-Cli: Cause it to shutdown

Ah you have spark-cli. Awesome!

Place the core in DFU mode and use the command spark flash --factory tinker

Next would be spark flash --usb cc3000

This will patch the cores to the latest updates.

Following that, place it in DFU mode again and run spark flash --usb tinker

We will now add credentials using spark setup wifi.

Send in your Wifi credentials and see if it works. :slight_smile:

I mean we are here to help and troubleshooting definitely take a while. The out of the box experience might not be that pleasant but help is available.

If you are interested, I’ll be happy to help. Otherwise, sorry for the frustration and good luck with your own stuff. :wink:

1 Like

Light is flashing yellow, ran the command. Got:

Apparently I didn’t find a DFU device? util said
Error writing firmware… no dfu device found.

Tried both usb ports on my laptop

Might need to try another USB cable. :wink:

You probably need to make sure you have the dfu driver installed, see here:

1 Like

Hey Brian! Random seeing you here :smile:

At any rate, I ran into something very similar… I had to scrap the USB cable… the USB cable that ships with the earlier units is pretty shotty…

Hope California is treating you well!

Is there a tutorial on how to setup the driver on a mac? A windows tutorial won’t do me much good. Also, hi Jake!

You don’t need a driver on OS X …

If your spark is flashing yellow and dfu-util -l does not show the device… I would bet money it’s a bad USB cable… I had that happen to 1/3 of my sparks…

@kennethlimcp everything worked up until spark setup wifi I got back:

I didn't find any cores available via serial
Potentially unhandled rejection [1] No serial port identified (WARNING: non-Error used)

Thanks for your help and patience

@kennethlimcp no luck. What’s the process for getting a replacement?

@brianthecoder, send a mail to with reference to this thread and they should be able to replace it.

@will here’s a case for you to follow up. :wink:


@brianthecoder sounds like a pretty tough first go at things…sorry for all of the issues. I want to make the following quick note, which is that there a couple different commands being suggested here, and the Core needs to be in specific modes for them to be executed successfully.

DFU mode = flashing yellow, works for
spark flash --usb cc3000
spark flash --usb tinker

Listening mode = blinking blue, works for
spark setup
spark setup wifi

This thread got tossed in my junk folder by my mail client :frowning: , so I apologize for the slow response. Let me know if you haven’t already been taken care of, and I’ll make it happen.