Two spark cores, same network: one works and the other won't connect at all

Hi guys,

I’ve got an interesting problem for you.
I got two spark cores a few day ago (Chip Antenna).
One of them worked GREAT out right out of the box. Literally took me 5 minutes to get it blinking an external LED. Very happy with it.

The other one starts up normally, settling at blinking blue. I try to connect to it and it just continues blinking blue. If I then reset it, it will then blink green as if it’s trying to connect to the router, but I see no indication of that in the router’s logs. I’ve tried changing the mode on it back to listening (blinking blue) and trying again, then a factory reset. The app obviously works with the setup here, otherwise the other one wouldn’t have worked so well.

I’m out of ideas and I’d really rather not try to set this up “manually”. I have a mac here and it’s just going to be a PITA. Any ideas?

Thanks in advance!

Hey @deathweasel—sorry to hear the setup on the 2nd one isn’t as seamless—check out the troubleshooting guide for a clear list of steps to go through:

Most strange is the fact that the Core continues blinking blue, never turning solid blue then green to indicate it has heard the Smart Config signals. Connecting the Core via USB isn’t too bad—instructions here:

If you’re comfortable using a terminal on your mac, here’s some more detail. Try connecting your Core to your mac with the USB cable, then do a factory reset. After it settles into blinking blue, unplug and replug the USB cable from your computer. When it again settles on blinking blue, in Terminal run sudo ls /dev/tty.u*. This should list at least one file with a name something like /dev/tty.usbmodem621.

You can run sudo screen /dev/tty.usbmodem621 (replacing the filename with the one recognized on your computer) to open a serial connection. Hit i to have your Core print its ID. Hitting w will let you enter Wi-Fi credentials. Factory firmware can only handle WPA2 networks over USB, but once your Core connects and updates, more security modes are available.

If you go through these steps and are still having trouble, go ahead and email me at Cheers!

I’m having basically the same problem. One spark core connects fine, the other one gets hung up on flashing green. I was able to get it connected briefly before when I temporarily removed the password from my router ( it was WEP) but after I changed it to WPA2, it hasn’t be able to connect. Tried all the basics, resetting, and manual entry of SSID and password, but no luck!

Hi @mikebuffington,

If you have one core working and one not, it’s possible one might benefit from having the wifi patch applied.


Success! Thanks so much!

1 Like

Looks like I have to download Xcode, all 2 gigs of it, just to install dfu on my mac. No thanks. Is there an easier way to patch this? I’m not trying to sound like a complainer, but I always get frustrated by things like this because it reads as an easy job on the surface but I always have to do a dozen more steps in an environment and language that I’m not familiar with.

Hi @mikebuffington,

I believe you can install dfu-util with homebrew if you have that setup , as well as from MacPorts:


David, When I try to install via Homebrew, I get this:

Warning: Xcode is not installed
Most formulae need Xcode to build.
It can be installed from
==> Installing dependencies for dfu-util: pkg-config, libusb
==> Installing dfu-util dependency: pkg-config
==> Downloading
Already downloaded: /Library/Caches/Homebrew/pkg-config-0.28.tar.gz
==> ./configure --prefix=/usr/local/Cellar/pkg-config/0.28 --disable-host-tool -
checking for gcc... clang 
checking whether the C compiler works... no
configure: error: in `/private/tmp/pkg-config-Uxti/pkg-config-0.28':
configure: error: C compiler cannot create executables
See `config.log' for more details
Error: Homebrew doesn't know what compiler versions ship with your version
of Xcode (dunno). Please `brew update` and if that doesn't help, file
an issue with the output of `brew --config`:

trying ‘brew update’ returns

Already up-to-date.

Running X11 to run MacPorts to install dfu-util… not the"Quick Deploy" that I was expecting…

Thanks for helping. I do appreciate it.

Just as a sanity check, both of your cores are “chip” antenna cores (white bar) and not u.fl cores (gold port) right?

The patch fixes certain issues on certain types of networks, but if you’re not in one of those ‘fixed’ situations then you should be able to get it online normally. The most major recent fix was that unpatched cc3000’s had problems on 10.x home networks ( you can see their release notes here: ).

I’m a bit bummed there isn’t a faster way to get dfu-util installed on a mac, I might need to look into that. :slight_smile:


Yes, both are chip antenna cores.

It looks like I’m on a 192.x home network anyway.

The weird thing is that I got this one working at one point, when I disabled the password on the router, but haven’t been able to get it back with or without a password on the router and I foolishly removed the core from the ‘build’ page/phone.

@mikebuffington we are working on tools to do USB flashing more easily, but they’re not ready yet; in the meantime, installing Xcode so that you can use dfu-util might be your only option.

For god sakes man, just install Xcode! Then you can benefit from using embedXcode (once it’s ready for the core) instead of Spark Build. ;D

Hi Zach and others. This fixed it. Thanks.

1 Like