Help with Breathing Blue LED

Hi all,

My core has been behaving odd. It has been good yesterday flashing the same code after the deep update.

Today I did some minor tweak, did the usual thing and flashed the Spark core. After the rapid flashing magenta (completing firmware flash), instead of going back to blinking cyan attempting to reconnect to the network, the LED turns to “breathing blue”, and then only after a few seconds it will then go into “breathing cyan”. However after that, the firmware is not running.

I experimented by resetting the core, reconnect to the network, then flashed the “Tinker app”. After the rapid magenta flashes, the same behaviour is observed.

I have tried rewriting the firmware through DFU and the behaviour is the same.

Thanks for your assistance!

Do you have a video of it breathing blue while running tinker app? :wink:

I will test to see if the tinker functions work first.

I have the same problem. Deep update, now only breathing blue. I can successfully go through the “spark setup wifi” or “spark serial wifi” command line option, it then resets and breathes blue again.

It sounds like some flag not set properly to tell the CC3000 that there are already existing Wifi profiles and not to enter Listening Mode.

Can you try a couple of factory reset and see how it goes? :wink:

Hi Kenneth,

That appears to cause the whole spark to crash. The factory reset works, but once I try “spark setup wifi” the blinking blue light freezes solid, or sometimes it stays off (frozen off).

Thanks

Ah. Was it working fine before?

It sounds like some corrupted factory reset firmware or something. Do you have DFU-Util or spark-cli installed? We can attempt to overwrite the firmware for both user and factory, do a test and see how it goes.

Otherwise, we might need to ask for a replacement if it’s new but not working :smiley:

I have both dfu-util and spark-cli. I have 3 devices here. 1 is working fine. I did the deep update a while ago before you released the news.

These other 2 are fairly new. Both have the same issues. I try to setup wifi and it freezes blue. One of the devices was online tonight and I tried the deep update from the spark.io/build and then it started having the issues.

I can use the dfu-util to do the deep update manually perhaps. I can’t remember the process though.

Ok cool!

Let’s do 2 things:

1.) Update spark-cli with npm update -g spark-cli

2.) Check the spark-cli version with spark --version. Make sure you have 0.3.97

3.) Place the core in DFU mode (Blinking yellow)

4.) Re-flash the core factory firmware with: spark flash --factory tinker

5.) Factory reset the core and watch the behavior.

If everything goes ok, we will do a spark flash --usb cc3000 to patch the CC3000 manually once again.

Let me know how it goes :slight_smile:

ok, I did “spark flash --usb cc3000” let it do it’s thing, then reflash tinker and ran “spark setup” and it worked. This was on the newest one which was before now unclaimed.

I got it working, but there is definitely a bug somewhere.

I tried on the previous one which I had already claimed. I repeated above…cc3000…tinker…setup. It seemed to work, I got breathing cyan, then rainbows, then it wanted me to name it (last step of setup) so I entered the same name it already had…oops…error, name already taken and then it didnt connect to the cloud anymore.

So I tried setup a few more times. spark setup, same problem as before, it crashes on after entering Wifi settings and the blue light freezes.

So again I burned cc3000, tinker, and did the setup again. This time it worked again. On the naming step I just Ctrl-C and now the unit works again.

So to my surprise reflashing the cc3000 firmware would bring it back to life. That doesnt make much sense to me. I would think the cc3000 firmware wouldn’t be corrupted by spark setup command but maybe I am mistaken. Anyway, something to take to the dev boys if you don’t mind.

@guru_florida, Is it safe to say that the cores are working fine now?

My guess is that the ‘deep_update’ via OTA was corrupted and did not patched the CC3000 properly.

I initially suggested you to patch using deep_update_2014_06 but changed my mind to cc3000 instead.

Great that it’s working! I will definitely bring this up to the team and sorry for the inconvenience. :wink:


@timolol,

you might want to try the steps here:

No, still not good. :frowning: It works for a few minutes then it drops the cloud a lot. This is on both devices. Strangely, the third one that I’ve been using for a month seems good. (I didn’t touch that one tonight.)

I give up for tonight. I will try some of your suggestions tomorrow.

Thanks,
Colin

Tried all that (for the 5th time). Still getting the errant behavior. This is tiring. Confirmed the spark version is 0.3.97 as well.

@dave, might need your help on this…

Hey All!

Hmm, reflashing the cc3000 patcher wouldn’t fix something if your core was already patched generally speaking. It would clear the saved profiles, so it’s possible if your wifi profile was corrupted or something…

Can you tell us about your WiFi network setup? Are you using WEP? Have you updated the firmware on your access point anytime, or how old is it / what model etc. Is your core a u.fl or chip antenna core?

As a sanity check, can you try a different USB cable / power supply as well? If nothing else, we’d be happy to replace that core if you have others that are working normally on your network, please feel free to email us at hello@spark.io and we’ll get you a replacement. :slight_smile:

Thanks,
David

I’m having very similar issues.

Going through
1.) spark flash --factory tinker
2.) Factory reset
3.) spark flash --usb cc3000
4.) Factory reset

It eventually fixed it for the black core, but my white core does:

1.) blinking cyan
2.) blinking red
3.) blinking cyan
4.) white
5.) blue (one breath)
6.) green
3.) blinking cyan (goto 1.)

Any pointers? Spark version: 0.3.97, node: v0.10.30.

I’m really puzzled but the behavior. It’s like some rare occurrences minority cores after patching.

Is the core rapidly blinking cyan?

It’s not the most rapid version of flashing, but faster than breathing if that makes sense.

So its breathing cyan but faster? Interesting.

Does it appear online in the WEB IDE or spark list in Spark-cli?

No, it fails to connect to wifi at all.

It sounds like rapid flashing cyan which indicates that it’s unable to reach the spark cloud (somehow)

Can you try with your phone hotspot and see how it goes?

Sorry for having the issue though!