Steady magenta after two seconds of breathing cyan

Hi, I have just claimed my spark core, everything goes fine up to the “breathing cyan” but then after about two breathes (two seconds) the led gets steady magenta.
I have tried to reset it many times, tries to delete the memory and redo the claim, tried with two different wifi AP, I get the same result.
I have gone through the previous messages but I have found nothing similar.
Any hint ?

Magenta only occurs when you are attempting to flash firmware OTA. Are you doing so?

Trying flashing a blank firmware and see what happens!

I have the same problem.
I connect to the cloud (cyan breathing) for a few seconds and then turn solid magenta.
I’ve tried factory reset several times.

over the CLI, when I “spark list”, I get “… is online” for a few seconds, and then after maybe 10 seconds, “… is offline”.

I can’t flash via webapp, I get the error “The server has failed to process the request on time. Please try again.”


What firmware are you running in the core?

Can you reset the core and try again? :wink:

I’ve got the same problem, I’ve factory reseted my Core two times and after trying smart config it breaths cyan and then go magenta. Is there a problem with the cloud? I have another Core which is working fine.

Okay, I found a working solution.
I wasn’t able to flash via webapp, and “factory reset” didn’t do anything.

I compiled the “Blink an LED” firmware and flashed it via USB DFU Mode.

from there, it connected to the cloud again and I was able to flash it with my own app again.

Yes, similarly I flashed the cc3000 update and the deep update over USB with the spark-cli and it now works.

1 Like

Solved by flashing via USB.
Not particularly easy, had to install a few components on my Macbook and troubleshoot a bit but finally it works.

1 Like