Spark Core suddenly stopped working correctly

OK this is odd. I’ve been using my Spark Core for the last week and had no issues. Running it off a USB cable in an Apple wall brick.

Now today for some reason it’s started to play up. The only thing I’ve changed is created a new project in the build environment, and it’s been brought home so had a power cycle.

Currently the Core is sat on my desk and the LED is breathing Cyan, but it’s showing as offline in the particle dashboard. If I reset the core it seems to connect and start breathing cyan and then a number of things can seem to happen.

This time it’s starting to breath cyan, then the flash fast green, then cyan breathing, then flashing green, etc and then sits there breathing cyan but again the dashboard says it’s gone offline.

I’ve also had it breathing cyan, then the LED going white, then fast cyan, then breathing cyan in a cycle.

It’s also on some resets got to breathing cyan and then flashing red LED ( I think 3 times but it’s real fast ) then fast cyan and breathing again.

The current project is a copy of the example in the PCA9856 library so doesn’t do very much, and there’s nothing connected to the I2C now and still the same.

I’m assuming this is something pretty terminal.


Are you on firmware 0.4.5?

Yes I checked this a few days ago and it says 0.4.5 in the build environment

Oh and I can’t flash any new SW into it now as nothing seems to happen, presumably as it’s resetting.

Hi @PeteStewardson,

Have you tried loading tinker back onto your core / doing a factory reset? It’s possible your app is preventing the core from maintaining it’s connection to the cloud?


I’ll have to try a factory reset tomorrow.

OK factory reset fixes the issue. It seems my problems may be down to the PCA9685 libraries being bad and causing resets :frowning: