Can't connect my spark core

I’ve just started working with spark core ; i had some problems till i make the app connect the core and added it to my account .

after several days i start to connect it again but it doesn’t work and it give me offline sign on the app .

so i reset the core and tried again but this time it doesn’t work :frowning:

i tried to connect it also using USB but same result :frowning:

any help i’ll really appreciate …

Hey @Omar, sorry you are having problems.

Let me check a few things.

  • When you say “reset” are you factory resetting or are you pressing the reset button?
  • If you did factory reset what have you done since the factory reset?
  • If you didn’t factory reset would you mind going ahead and factory resetting the device?

Well yeah
i press the reset button while holding the mode then following steps till it’s blinking blue

then i try again to connect the core using the app .
but still the same problem as in the video

Note : that when i open the tinker app
i still see the name of the core as i added before but its offline

Ah, ok. So the wifi credentials are now all gone (that’s one of the things a factory reset does) so you will need to re-add the core using the tinker app. Are you doing that? I only ask because near the end of your video it looks like the core is going through the following steps:

  • Blinking blue
  • Blinking green (looking for a wifi point)
  • Blinking cyan (connecting to the cloud)
  • Dark / Video cuts out. What happens after blinking cyan?

yes i tried to reconnect it again
but here what it does
blink blue then green then cyan then green again then cyan and so on
never connect eventually
so it keeps blinking as shown in video

1.) Did the core ever reached breathing cyan?

2.) Were you able to control the core previously using the tinker app?

3.) Was a new program flashed to the core via the Web IDE recently?

In the video, it looks like your core managed to connect to the Wifi network but attempts to connect to the Spark :cloud: is an issue. How’s your internet connection over there? Also, answering my questions above will be helpful ^^

1&2) Well it used to be working normally before
so it was breathing cyan and i was controlling it well by tinker app

  1. no there were no program flashed to the core

Ok that’s really useful to continue troubleshooting your core!

Did you try to perform a factory reset and send in Wifi credentials again via the tinker app?

yess and what happened in the video was the result and it keep on going like that and never reach breathing cyan

Hmmmm. I guess there’s no change to your router as well?

1.) Can you set up a Wifi hotspot on your phone?

2.) If you can, send in the Wifi credentials via USB in listening mode and see if the core can connect successfully using the hotspot.

Hey man @kennethlimcp it works now :smile:
Thanks alooot

Hey @Omar, good to hear that!

Let’s have a little closure to this issue. I believe there might be some configuration that we need to figure out for your Wifi network in order for the core to connect successfully.

Do post back if you need more help! :beers:

@Omar, would you mind letting us know what you did that fixed it? Did you get it connected to the hotspot or the original network (or both?)

well i reset the spark core then using cmd and hotspot it works well ;
but still with WiFi facing the same problem

Ok @Omar, I’m unfrotunately not sure where to go from here.

When you say “it works well” and then “facing the same problem” are you saying that when it works, it works well, but you are, every so often, running into the same issue as in the first post in this thread?

OK let me clarify more …
It works well when its connected to 3G hotspot
but when i connect it to my WiFi router it doesn’t work

Ah, ok. That clears things up very nicely.

What is your wifi network’s configuration?

SSID Length/Special characters? Security Type? B/G/N? Perhaps there is an issue with the way your network is configured

1 Like