Can't connect. [SOLVED]

Just got my spark kit, 2 hours later I’m still trying to connect. The serial method (mostly) worked 1 time now it won’t connect. The android app was a bust, and now the TI app says it’s “working.” The only problem is nothing works. So exactly how is product development supposed to be effective for a consumer device if a somewhat decent technician can’t get it to connected?


What is the issue you are encountering?

We can help with troubleshooting :smile:

Let us know the following:

  1. RGB Led status/colour

  2. Chip or u.fl antenna

  3. Colour of core

  4. Network router settings (Security, mode)


Hi - and I had an issue once when I bricked my core and it acted similar to what you are describing. Please try a factory reset described in the below forum post by one of the Spark Elite; it fix mine. Lets us know if it fixes yours. I have no connection to the Spark Team or company I just am a previous Android / Ethernet user that loves my spark core; not perfect but worth it.

  1. The led is blue flashing.

  2. Chip

  3. The PCB is black if that’s what you’re asking

  4. Router is WPA2 Personal. Auto channel assignment.

Flashing blue means the core did not received any Wifi Credentials.

If you are using USB, plug it into your laptop/machine and open a Terminal

Press w and enter your SSID, password and security type.

It will go from flashing blue --> solid blue --> blinking green --> blinking cyan --> breathing cyan

Let us know which color did you reach :smile:

Give it a try? :smile:

Thanks. That worked. It’s breathing cyan now.

1 Like


have fun @kevmiller :smiley:

1 Like