Impossible to get my Spark Core on wifi

Hi all!

I am having serious trouble with getting my Core on my wifi.
It used to work, but its been on the shelf for a couple of months now.

Option 1 - Connecting the core thru the app

  • This has never worked

Option 2 - Connecting from the Terminal/coolTerm

  • This seemed to work. I get to input/choose the network, choose security and enter the password.
    Now after this I get the message that everything is good to go. The spark just have to connect.
    But after that the spark just loops thru a bunch of colors:

Solid blue
Blinking green
Blinking blue
blinking slow red x3

and then over again.

Ive had trouble with this spark before, then I solved it by altering my network setup. But now its on the same network so I can’t understand why it won’t log on.

I´ve tried contacting Particle by mail, but no answear yet.
The Core is about 1 year old.
any ideas?

One of the things you could try is to factory reset the device.
When it was not in use for that long, I’d assume you can’t really tell what code was flashed to it last :wink:

And is it really blue (only one sub-LED of the RGB) or rather cyan (red and blue sub-LED)?

I’m also not sure, if you already had a non-expiring access token for that Core. If not, you might need to renew your access token, too.

1 Like

Hm. I have done the factory reset a bunch of times. Have not looked in to renewing the access token tho. How can one do that? is it possible to do without having the Core connected to wifi?

You can renew the token in several ways, but one of the easiest is via

At the bottom left, you’ll see a gears symbol and there you’ll find a button to reset your token.

Do you remember, if you ever did a CC3000 update (or deep_update)?
What colors does your Core show during factory reset?
Or your cloud key might be broken (see second link).

But you might also find some useful hints in topics with similar symptoms, like
3 red LEDs cloud failure?
Red LED blinks three times when trying to connect to the wifi network

BTW: If you read about commands like spark keys ..., this refers to the so called CLI tool, which is now particle keys ... and installation instructions can be found in the docs.

I have done the CC300 update. The core was blinking magneta and then went back to blinking orange/yellow if i remember correctly. I have been using the particle CLI tools with the terminal. unfortunately im at school right now, but I will try this out as soon as I get home. Kind of loosing hope, but I cant give up;)

As far as I remember the factory reset should actually blink white, not magenta.
And when done it should go into Listening Mode (blinking blue).

Have another try, and this time don’t let go of the MODE button before the Core blinks rapid white.

The factory reset is blinking white, but when im doing the CC3000 update it blinks magenta and then goes back du yellow/orange(DFU)

It’s long ago that I actually did this with my Cores, but up to a certain time, the CC3000 update didn’t survive a factory reset and you had to do it each time after FR.
To check if your CC3000 still is in place, you could go into Listening Mode and enter the WiFi credentials.
If you get asked for WPA2/WPA/WEP/open, then CC3000 is up to date, if not, you’ll have to do it again.

If FR and CC3K don’t help, it might be a key issue, and you might have to call on someone like @kennethlimcp (some master of the keys ;-))

1 Like

Place the device in DFU mode and run:

  • particle flash --usb tinker
  • place in DFU mode again
  • particle flash --factory tinker
  • particle serial wifi

After factory tinker the Core doesn’t automatically go out of DFU, so I press the reset button. After that: particle serial wifi
and I get this message: ! serial: No devices avaiable via serial.
I put the Core in listening mode
type in SSID, security and PW
The Core goes back to the blinking loop…