3 red LEDs cloud failure?

Connecting my spark core to the cloud is failing with 3 red LED flashes

The Spark Core has been previously registered and was running a simple LED test, but now it runs through the connection sequence (green flashes, cyan flashes) and ends with 3 red LED flashes, before resetting According to the start page, 3 red LEDs means a cloud problem, but the status page suggests everything is working.

I’ve tried the following, which don’t help. a) 3 second MODE reset, b) 10 second memory clear and restart, c) USB SSID programming.

I guess my question is: Is the Spark Cloud working or is the status page incorrect? Is there anything I can try to resolve this issue?

The saving grace is usually the Factory Reset: Hold both buttons, let go of reset, wait for the led to flash yellow, then flash white… let go of mode and wait a while until you see the slow blue flashing led. Now you can use SmartConfig or a USB Serial connection to get your core back on the WLAN. After that it should be back up and running. Fingers Crossed :smile:

1 Like

I did factory reset it, or at least tried to. It’s possible I failed and instead put it into DFU mode each time. Either the factory reset helped this time, or the different USB wall-wart worked, or the problem cleared itself somehow. Thanks for your help.


@eelsirhc just for future reference, you can configure the Core into factory reset mode by continuing to hold the MODE button on the Core while it goes into DFU mode (flashing yellow). I always think of factory reset as “beyond” DFU mode, but that might only make sense to me :smile:

Is there any variable or function that can be referenced to within the code to check whether Spark cloud service is available or not? In other words, is there any way I can figure out within the program that is equivalent to 3 RED LED Flashes?

I ordered four SparkParticle Cores back in February. All of my debugging, testing, etc. has been done with just one. I finally decided that it was about time to open the other three boxes, and claim the Cores. The claiming/WiFi setup was uneventful on two of them, so that makes three out of four.

The fourth one…it booted to “connecting” (instead of blue flash, “listening”)—and this is the first time I’ve powered these up, too.
Anyway, after struggling with being unable to setup WiFi credentials on this Core, I did a factory reset. This time, the credentials easily went in. BUT…it won’t connect to the :cloud: ! Immediately after a factory reset (I’ve done it three times now), it goes through the connecting pattern: flash green -> flash cyan -> three red flashes -> fast-flash cyan for about 5 minutes. It then goes to breathing cyan…so I go to test Tinker (which doesn’t work), but the Core is immediately back to the fast-flash cyan for another couple of minutes. On subsequent power cycles/resets, I don’t get the three red flashes, but the problem remains the same.
Interestingly, it shows up on the Dashboard as having been connected. As I was able to claim it, some sort of link is being made, but not one that allows Tinker (or user code) to run.

I’ve tested Tinker on the other three Cores, and they work perfectly. Ping @BDub?

EDIT: I should be a little more patient, even if I get nothing else done in a day’s work. Particle Keys doctor didn’t work (actually, it can’t find the Core, errors “type undefined”, and fails—but I can DFU the Core with no problem). A CC3000 flash did the trick; I suspect that this Core somehow escaped the factory update before being shipped.