Red LED blinks three times when trying to connect to the wifi network

Hi,

I’m getting three LED blinks when trying to connect to the cloud.

I could connect my core to the cloud before and then I tried setting up a local cloud server and connecting the core to it. I could successfully fire up the server though when I was trying to connect the core to the local cloud, it didn’t get connected.(Apparently it was a handshake problem which I found out later when checking the server logs.) Then I tried to connect it again to the spark cloud and from that point onwards I’m getting three LED blinks in between cyan and green flashes. (3 red blinks->6 seconds of cyan flashes->1 second of green flashes->6 seconds of cyan flashes->3 red blinks)

When I read up in the forum it says that it’s a memory mangement fault. How can i fix it? I tried the factory reset a few times, ran keys doctor, flashed the 33000 patch but couldn’t get it to work yet. :frowning:

Any help is really appreciated!

Thanks a lot!

Did you also revert the server public key using spark keys doctor?

I think the blink counting only works if your Core is flashing the SOS pattern first.

I was seeing the same thing as you on my core the other day (after it being packed away for several months), and I think resetting the public cloud key was what finally got it working again for me. Try the instructions from the first post here:

https://community.particle.io/t/switching-your-core-back-to-the-spark-cloud/5583?redirected=true

Hi Kenneth,

Yes, I tried that as well. The second time I did it the dfu-util gave the message that the file already exists. So I guess it was reverted properly.

But does it only keep one certificate at a time or is there a chance that the certificates I uploaded for the local server still exist?

Thanks a lot for the response!

It shouldn’t have that error. Download the :spark: :cloud: key at: https://s3.amazonaws.com/spark-website/cloud_public.der

the command will be spark keys doctor cloud_public.der

Hi dougal
I do not have access to that post :confused:

Ah, it’s in the beta forum, which is locked. I’ll quote it here:

1 Like

This may or may-not be what finally solved my problem on Friday. I tried so many different things, I don’t remember now. But if you still don’t have luck, maybe I can look at my computer at home tonight and see what else I can recall from my browser history.

Hi Kenneth,

I’m getting the following when trying to do that.

***************************************************************
   Warning! - core id was shorter than 24 characters - did you use something other than an id?
   use spark identify to find your core id
***************************************************************
running dfu-util -l
FOUND DFU DEVICE 1d50:607f
running openssl genrsa -out cloud_public.pem 1024
running openssl rsa -in cloud_public.pem -pubout -out cloud_public.pub.pem
running openssl rsa -in cloud_public.pem -outform DER -out cloud_public.der
New Key Created!
running dfu-util -l
FOUND DFU DEVICE 1d50:607f
This file already exists, please specify a different file, or use the --force flag.
Error saving key to core... This file already exists, please specify a different file, or use the --force flag.
Make sure your core is in DFU mode (blinking yellow), and that your computer is online.
Error - This file already exists, please specify a different file, or use the --force flag.

Hi dougal,

Can you please explain me the last point? I’m sorry but I’m pretty new to the spark community.

Although when I did spark keys server cloud_public.der and tried spark setup again, now it gives one second cyan flash and half a second red flash in a loop.

Thanks a lot for your help!

Ah can you do it in an empty folder instead as the command will generate new keys for the core as well.

Sorry the command should be:

  • spark keys server cloud_public.der

  • spark keys doctor CORE_ID

Hi Kenneth,

I followed your steps. Now it keeps flashing cyan in a loop with half a second red flashes. It’s difficult to identify any pattern as to when the red flashes are occurring.

Any ideas?

So i presume you ran the 2 commands bother correctly?

Flashing cyan seems to suggest that the core is not connected to the :spark: :cloud: which should have been resolved by the changing of server public key.

The scenario you should see is rapidly flashing red/yellow for bad keys.

Yes, I ran both of the commands without any problem.

I just tried connecting the core :spark: to the :cloud: using the mobile app. It says that We found a core and let’s name it. But the core doesn’t shout any rainbows.

Will it help if I do a factory reset, flash the c33000 patch, tinder, then issue the two commands to fix the public keys and then try it? I’m sure whatever the problem I was facing earlier is not there now since the flashing pattern has changed.

Any help would be really appreciated! :slight_smile:

That shouldn’t be required but maybe a factory reset would be good :wink:

So factory a reset and try to connect the :spark: to the :cloud: ? Should I use the app or the spark-cli?

1 Like

Let’s go for Spark-cli!

1 Like

No luck… still the same flash sequence as before :confused:

Okay the flashing sequence is a bit weird now. Moment ago it was only flashing cyan, then cyan was on for like two or three seconds(no flashes no blinks), then 1 second white, then again 1 second cyans and half a second reds :confused:

Let’s do this over again:

spark keys server cloud_public.der

spark keys doctor CORE_ID

Did you replace CORE_ID with the actual core id?