Spark core flashing green after wifi reset

Hi,

I’m using spark on a local network and had to perform the reset of passwords using table by pressing the mode button for 10 seconds. After this mode button pressed for 3 seconds and add the new wifi credentias using: spark setup wifi, after completing the spark restarts and is only flashing green. Can anyone tell what may be the problem, this is the second spark happens the same problem

@rbbahia, did you do a factory reset then set your credentials? Are you running your own code on the Core or simply the factory Tinker?

While holding down the mode button for 10 seconds, it does not performs a factory reset, am I right? The application that was in it before the reset was mine. After this reset did not install the application again, because I think it was not a factory reset, am I right?

@rbbahia, which SYSTEM_MODE are you running you app with?

Sorry but I do not understand your question, as well as which system mode?

http://docs.spark.io/firmware/#system-system-modes

automatic mode

Flashing green in automatic mode

I change to “manual mode” and on void loop insert:

SYSTEM_MODE(MANUAL);

void loop(){
Spark.connect();

and yet flashing green

@rbbahia, SYSTEM_AUTOMATIC was fine. It may be that your wifi credentials are not working or your code (loop()) is not “ending” in order to pass control back to the background firmware. Is the light flashing green or breathing green?

Is flashing green. Before reset, my code working fine. I tried now other app, and the problem is the same. and this is the second core with the same problem.

@rbbahia, flashing green means the wifi is not connected. Can you tell me more about your router?

Before working with a d-link 905 router. I tried with a Unifi router, and has problems so I made the wifi reset, now don’t connect in d-link 905 and before works fine with this router.

Before you saw him trying to connect now to connect indefinitely is flashing green, it looks like he does not even try to connect.

@rbbahia, I suggest you do a factory reset of your Core and reset the wifi credentials and see if it connects.

ok I’'l try it and send a feedback later

here you can see the movie with flashing green
https://drive.google.com/open?id=0BxdPaeBxbhzjSHRmZF8ySjZvMHM&authuser=0

I made the factory reset, then flash the cc3000 and then fhash my app and for finish add the wifi credentials. But the led is flashing green yet

@rbbahia, flash tinker instead of your app then test.

I made the Tinker flash, but the problem is the same. If I try insert the credentials using the Androip app the core is flashing blue, so I insert the ssid and pass em click continue, the core fix blue and after 2 segonds flashing green again, And the android app after one minut say no cores found,

@rbbahia, do you have the correct SSID? Does you password have any spaces or weird characters?

Not actually your problem cause, but if you do it that way I’d guess you’ll have troubles since you keep retriggering Spark.connect() before it actually finished, possibly causing it to never connect.
And for MANUAL you’d need to call Spark.process() regularly (not Spark.connect()).