Failed connecting to WiFi

So,

I managed to get my first Core working and it all worked fine. Then I have my second one. Followed the same setup - power up, fire up App, write the WiFi details - all good. It flashed green… and that was it… kept flashing… infinitely.

I’ve restarted the app, cleared memory, unplugged USB multiple times. I’ve also tried setting it up over USB to manually set the SSID and password. No luck. It doesn’t seem to be able to connect to WiFi.

Powered via 1A output charger, next to my WiFi.

Note: My other Core ( I have 2 ) works fine. I can write new code via online IDE upload, etc. All good. On this very same network.

1 Like

Hey,

That’s exactly what mine does, but I’ve only got one so I can’t work on another one. I hope someone has a fix for this.

Flashing green means that it’s attempting to connect to your Wi-Fi network but cannot succeed. The most common reasons for this are:

  • It’s out of range of your Wi-Fi router
  • It’s a u.FL connector Core, and it needs an antenna
  • You mistyped your Wi-Fi password during set-up and it has bad credentials; clear the Wi-Fi memory by holding the MODE button for 10 seconds to get out of this

Let us know if any of those work!

Hi,

Thanks for the reply.

  1. As mentioned, WiFi router is within an arm’s reach

  2. I have a chip antenna

  3. I have made very very sure that the ssid and password is correct - multiple times via Android app and multiple times via USB

  4. Yes, as mentioned, i have reset, cleared memory, unplugged and retired the whole shebang. Multiple times.

I have 2 cores, one worked the other didn’t.

Is there any way of debugging it? I’m worried it may be a faulty item. :frowning:

1 Like

If it is faulty we’ll definitely replace it, but would be great to first ensure that’s the case, especially if others are running into the same issue.

Would you mind taking a quick video/vine/instagram/whatever of the flashing lights that you’re seeing? Would help to make sure we know exactly what you’re seeing.

1 Like

I am having exactly the same problem.

Tried 3 different access points, two different Android devices to set it up, two different computers using USB to set it up, pasted the WiFi key from the router config page so it HAS to be correct, reset the Core to factory default and tried again (repeated with every permutation of access point and setup method) and nothing works.

The core responded to being given WiFi credentials via the Android app every time, so it looks like the hardware is working OK. Did the whole production batch use exactly the same firmware revision? In the CC3000 as well as the Arm?

Hardware design and embedded programming are the day job, so if you can think of a few tests for me to try then just ask. I suspect the problem will be easy to fix once the cause has been pinned down!

1 Like

I’m having exactly the same problem as visualdensity… two cores both with chip antenna, one working fine but the other stuck at the connecting to WiFi stage (flashing green LED). Have tried factory reset, multiple networks, iPhone and android apps as well as via USB with no success. I tried leaving it to connect for over half an hour (other core connects within seconds) but still nothing.

Thank you all for the reports. Can one/all of you please take a quick video through whatever easy means (Vine/Instagram/whatever) of the LEDs that you’re seeing? Or compare to this: https://vine.co/v/hFwubhA3JXV

Also @nigle and @Blocky82, what are you using as a power source?

@nigle to answer your question, the entire production batch got the same firmware on both the CC3000 and the STM32.

One possibility is that the CC3000 firmware update that was done on the manufacturing line didn’t take; we could try to apply the patch over USB and see if that works. If anyone wants to volunteer to be guinea pig for this, let me know.

Both cores were being powered by a laptop, here is a video of the failing core straight after a factory reset
https://drive.google.com/file/d/0B5w9AYAB7R2DZ0MwbW9tZWNBaXc/edit?usp=sharing

You can see that the green light flashes until the app times out and will stay in that state indefinately

I’d be happy to try patching via USB

@Blocky82 Cool. We’ll prep the patch programmer so you guys can run it, and will share instructions tomorrow morning. Sorry for the delay and thanks for working with us!

2 Likes

[quote=“zach, post:8, topic:648”]
@nigle what are you using as a power source?
[/quote]I tried powering it from a desktop PC, netbook, powered hub and lab power supply. The lab power supply suggested that it was drawing something like 100mA - a bit difficult to tell on an analogue meter with 3A full scale.

I am up for that. I believe this involves using the WinUSB driver, which breaks the COM port interface? It certainly did when I tried it, before discovering the .INF file for the USB CDC class!

I confirm to have the exact same behaviour as @Blocky82.

Same behavior here, though I’ve tried it with three APs over both USB and the app. Frustrating though it is that it won’t work, it’s been awesome to see this thread progress throughout the day. I’m confident y’all will get to the bottom of this in no time.

1 Like

Just got my core today. I’m having the same issue. I have an airport extreme N router, but when I logged into airport utility, it says (b/g compatible) in parentheses next to 2.4 ghz section. I also tried using the guest network too with no success. I also held the mode button for 10 seconds to clear the memory, force closed and reopened the app, and rebooted the phone. Also replugged the sparkcore. No luck. Any ideas?

Hi @sky, and @Ratsark,

Just to check, can you confirm which light pattern(s) you’re seeing on your cores, and if possible, which phone model you’re using with the apps?

Thank you!
David

It looks like I am having the same issue. I have the chip antennae with the non-stop flashing green. I also tried to connect via terminal but it’s not transmitting anything in listening mode. I just get a blank terminal screen.

Note- I never actually get a flashing blue, i just get static blue after holding down 3 seconds. Holding for 10 doesn’t change anything, it continues to stay in static blue. If i hit the reset button, it does the white startup flashing for a few seconds, then goes right back into flashing green.

Connecting via iPhone just reports no cores found.

Hi @Layne,

If your core doesn’t flash flue (only solid blue), maybe try a factory reset? Hold down both buttons then release reset. Keep holding the buttons until the light flashes bright white.

Thanks!
David

1 Like

iPhone 5s on latest firmware (no updates available when I check). I’m powering the core with my 4 amp limeaide brand (also from kickstarter!) usb wall wart. the light is flashing blue

I tried the factory reset that you mentioned to someone else and now it works!

1 Like

Hi @sky,

Thanks for mentioning this, I think this should be a first step for anybody experiencing the “my core only ever blinks yellow” problem as well. I’ll post that in that thread.

Thanks,
David