New core. Unable to connect. Flashing green

I have tried connecting my newest core to several networks. WPA,open,WPA2 with no luck. Always goes to flashing green.

Hi @haywardt,

Can you try the troubleshooting steps here and see if those help?


Also, there have been reports of some TI wifi module firmware versions having trouble with connecting to access points with SSID broadcast switched off.

If that is the case for you, try temporarily turning SSID announcements on. If that fixes the problem, get back to us here and I’ll try to dig up other posts in this forum that deal with upgrading the TI module firmware.

Sanity check: I have a mix of 'cores, some with on-board chip antenna, some without. The other day, I spent at least 15 minutes wondering why a new core out of the box would not connect. You guessed it. It was the first time I had tried to use a core without a built-in chip antenna and I was acting on habit. Connecting an antenna fixed the problem.


If you need help do post back :slight_smile:

I’ll be able to work with you and see what’s going on


chip antenna. Still cannot connect. I get an error when trying to install the USB driver. Here is the event log message:

Driver Management concluded the process to install driver FileRepository\spark_core.inf_18ba4ca4\spark_core.inf for Device Instance ID USB\VID_1D50&PID_607D\8D8E177C5055 with the following status: 2.

I was going to try and reflash it and it is in DFU mode. Can you point me to the DFU driver and the DFU Flasher and binary?

Here is the screenshot while trying to install the regular driver. The only two files in the zip (now expanded) are the .inf and .cat

Which windows version are you on?

When you plug it in, go to device manager, right click the device and choose uninstall driver and also check the uninstall from system option.

Replug in and install the driver again. When they ask whether to installer due to some conflict/driver issue, press continue anyway

Running 64bit vista. I don’t have the option to uninstall from system or delete driver files. I don’t get to the point where I get the continue anyway prompt. I just get the message show above, whether I choose to install from “Browse my computer” or if I go the “have disk” path.

The option is in the dvice manager.

Plug the core in and go to device manager and look for the core :). Do a right click

Oh wait. Are you putting the core in DFU mode or normal serial?

I can uninstall the driver, just don’t have an option to remove the driver files.

If you want to install the DFU driver, follow this tutorial:

dfu driver is installed, but I don’t have an image to flash. Where might I find the spark image?

Ok great! Are you trying to solve the flashing green problem?

If so, download the patch programmer here:

And the command would be:

dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -D cc3000-patch-programmer.bin

When the Patch Programmer is installed, the LED should turn off. Press the MODE button for one second to install the Patch; the LED should start flashing magenta.
When the patch has been successfully installed, the LED will switch to solid magenta.

To reboot back into the Spark Core standard firmware, hold the MODE button for 10 seconds while the Core is powering up (as above, to get into bootloader mode). This will activate a factory reset; if it is successful, the LED will flash white, and then the Core will return to its previous state (but with new firmware on the CC3000).

@dave, may I suggest to explore whether it’s possible to check the CC300 firmware version somehow? :slight_smile: I’m not sure if the CC3000 stores it in EEPROM.

It might be really handy when you all roll out the CFOD patch to assist :spark: owners with issues.

Maybe also useful for production check :slight_smile:

1 Like

Ok. everything worked great up until sending wifi credentials(flashing blue->solid blue->flashing blue. Then it goes from flashing blue to flashing white, then red, then blue (and the app times out). I then cleared memory again by holding mode until I get fast flashing blue, I try to reconnect. Now it appears that the core is connected but the app tells me “no cores found” so it appears I am unable to claim it.

So it is connected now!! Yeah! I am unable to claim it. Boo!

There shouldn’t be flashing white.

Perform a factory reset and send credentials again :slight_smile:

Once the core is breathing Cyan, look under the menu option on the Tinker app for reflash firmware

Have several times. I am getting the slow throbbing cyan like my connected core does. (The phone that I am running the app on has no cell signal but is connected to the internet through wifi if that makes a difference)

I still am unable to install the serial drivers. It appears it cannot find the mdmcpq.dll, usbser.sys and serenum.sys files. Again this is 64bit Vista. Without the serial drivers I am unable to find the device ID or I would try and claim it using spark/build

I cannot reflash tinker because the app only sees my original core, not this second one.

and claimed.

I was stuck until re-flashing it in DFU mode. It seems I had to do that with my first one too.

The app seems to time out too soon after it has been re-flashed as it timed out during the flashing magenta period. Then it seemed to take a reset to fast flashing blue, but even then the app didn’t see the core as connected when actually it was. After claiming the core the app crashed. I sent the crash report.

The issue with the serial drivers is still there. Missing files that are in the manifest in the .inf.

The rest of this I could overlook as it just took doing the same things a bunch of times.

1 Like

You need to mention what is the problem. Serial? DFU? Listening Mode?

If you are able to download the CC3000-patch, i don’t see any issues with the DFU driver. So my guess you are talking about the Serial (listening mode aka blinking blue)

I don’t have a Vista machine and can’t test out. But it should work fine.

  1. Download the drivers again:

  2. Plug the core to your machine and press the HOLD button for 4s for listening mode. Your machine should detect the core.

  3. Go to Device Manager, look for the core and right click.

It should be listed under other devices or COM Port for you. Mine’s an old screenshot for DFU

1 Like