Can't connect, only flashing green

So being back home after the Christmas holidays my Spark is having trouble connecting to my network.
I have tried almost everything I have found on the internet. Factory resets, different routers, using usb or tinker app setup.
I’ve also tried trying to apply the new cc3000 patch, however All that I’ve tried I only get back “no dfu device found”, I have all the dfu things installed and have my spark flashing yellow. I have tried this on my PC and macbook (win8 and 10.10).
I have also tried this dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -D cc3000-patch-programmer.bin with the .bin file sitting on my desktop. This also returns “No DFU capable USB device available”.

I’m not sure how to fix this, what can I do now?

-Spark version 0.4.92
-Dfu version 0.8

Maybe you can try to run the command prompt as administrator and ensure that the core is in DFU mode (blinking yellow) :wink:

Yup defiantly tried that. Not sure what I might be missing :frowning:

Does the Sparkcore show up in your device manager while in DFU mode? It should.

It does, it shows up as “CORE DFU” in “Other Devices” and has no driver. Is this correct?

Not quite but close. You need to download Zadig and install the driver. I suggest you follow this tutorial:

Thanks this made it work. I successfully installed the patch but still have the same problem of the LED locked on flashing green. I have been connected to this network before and nothing has changed about it. Is there anything else I could try or do I need to contact ""?

Yea, I’d go ahead and shoot an email to A replacement might be in order.

I had this same problem - core connected fine for weeks, then one day it does not.

I believe my problem was a marginal WiFi signal in the location of the Spark Core. Yes, it worked for weeks and suddenly stopped. However, when I moved the Spark Core closer to my WiFi access point it was able to reliably connect.

Since then I have moved my SC around my house. Even back to the original spot and it worked again - for a while - then got into this continuous flashing green. Perhaps interference from another radio source is changing over time? Don’t know.

In the end I don’t have a concrete cause, but empirically I observe that the Spark Core can reliably connect when it is just 10 feet from my access point.

I am using the on-board ceramic antenna. BTW, other WiFi devices in the “problematic” location have no WiFi connectivity issues that I know of.