SOLVED?: Flashing green after it worked for weeks

My Spark Core has been working for weeks. Now I cannot get it to connect.

When I power it on it starts blinking green, then it goes to breathing cyan for about two pulses, then it goes back to flashing green.

I could not find this specific blink sequence on the forums.

I have tried going back to factory settings, several times, and using Tinker to give it WiFi credentials again. This often, but not always, works (Tinker asks me to name the core). After Tinker asks me to name the core the core continues to flash green.

I have done a

spark flash --usb cc33000

it ended with this

File downloaded successfully
Transitioning to dfuMANIFEST state
Error during download get_status

I tried rebooting my WiFi router; that made no difference.

I don’t think it’s my WiFi router model, since the Spark has been working here for the last month or two.

What advice can you give me?


Here’s the entire update output in case this tells you anything. Since it ended with “Flashed!” I assumed the errors were not significant.

checking file  /usr/local/lib/node_modules/spark-cli/binaries/cc3000-patch-programmer.bin
spawning dfu-util -d 1d50:607f -a 0 -i 0 -s 0x08005000:leave -D /usr/local/lib/node_modules/spark-cli/binaries/cc3000-patch-programmer.bin
dfu-util 0.7

Copyright 2005-2008 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2012 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to

Filter on vendor = 0x1d50 product = 0x607f
Opening DFU capable USB device... ID 1d50:607f
Run-time device DFU version 011a
Found DFU: [1d50:607f] devnum=0, cfg=1, intf=0, alt=0, name="@Internal Flash  /0x08000000/20*001Ka,108*001Kg"
Claiming USB DFU Interface...
Setting Alternate Setting #0 ...
Determining device status: state = dfuERROR, status = 10
dfuERROR, clearing status
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 1024
No valid DFU suffix signature
Warning: File has no DFU suffix
DfuSe interface name: "Internal Flash  "
Downloading to address = 0x08005000, size = 25240
File downloaded successfully
Transitioning to dfuMANIFEST state
Error during download get_status

That’s weird and a cc3000 patch should have fixed it.

Did you update Spark-cli before performing the patch? :wink:

“… should have fixed it” - hmm. I’m more concerned what the “it” was that suddenly needed fixing.

Things should not work for and then suddenly act like they lost WiFi credentials.

Were there any other events associated with this, even ones seemingly unrelated, like power glitches ?

Kenneth - good point. I did update spark-cli before doing the firmware update.

Andy - I agree with you that it shouldn’t just stop working. There were no other events that I know of. The core runs on a good USB port, but I have tried a second port on a different device, just in case.


Hi Jim,

Do you fully admin the router? Anything an ISP might have changed? E.g. if WPA2 ciphers were changed that might knock the core off. Please try clearing the credentials and re-entering them again so that gives the cc3000 a chance to re-examine the wifi security.


I have seen a few times where power issues have caused the problem, flashing the cc3k update does something that fixes it, someone did say they needed to do it 3 times to get it to work.

Like you say the flashing cyan may be a clue to something… maybe its connecting then dropping. @digixx did you notice the cyan flash at all when you had the green flash issue?

1 Like

Yes, I admin the router. No, credentials have not changed. I have tried a factory reset of the Spark Core and gave it credentials again with Tinker. I have rebooted the router. All had no effect.

I would try out with a hotspot on my phone if there’s nothing i can get out of the repeated testing :wink:

This morning things are a bit different. Now it connects after I reset the Spark, then it goes back to blinking green, then sometimes reconnects, sometimes not.

I moved the Spark to be closer to the access point and it connects more reliably. I don’t know what changed. It used to work very well in my office and now it doesn’t. Either my WiFi signal has degraded or the Spark Core’s ability to pick up the signal has decreased.

I wish I knew what happened. I want to put this in a product, but the customers won’t be able to deal with this kind of thing.


You can consider the u.fl version that allows an external antenna to give some extended range for added reliability.

Would have been nice to know what’s the issue but shifting made the connection more reliably sounds like some sort range/ signal strength issue. :wink:

Glad it’s sort of resolved in the meanwhile!

Can you tell from a site survey if additional, conflicting access points have been added that might be inducing range problems ?


@AndyW: No additional equipment has been added to the network… With the exception of a new iPhone 6.


Any potential for changes that are within range and not owned by you ?

1 Like

@AndyW I live in suburbia and there are lots of WiFi networks around here. However my other devices all think that mine is the strongest signal. I think I need to use Spark’s with an external antenna. Without that it seems too dicey.


Maybe also check that the antenna on the core is still intact - I know of one case where someone managed to crack the antenna by accident, and spent some time trying to figure out why the core wouldn’t connect.

1 Like