Spark Core trying to flash infinite loop

I have been using my core every day, except today it stopped letting me flash it.

I seem to have got stuck in a loop trying to fix it - this is what ive tried 3 times :

factory reset
flashing blue (not breathing)
remove core from web app
add core in phone app
core flashes green
no cores found in app
unplug usb
replug in usb
flashing green

I also tried, putting into yellow flashing mode and :

spark flash --usb cc3000

I have a few other cores which are still working fine.

Try the patch again and resend the Wifi credentials

Ooops - I meant to say I get no dfu device found when its flashing yellow.
I tried it again right now but same result.

Im flashing other cores no problem so I think my setup is all fine.

Hmmm… Weird. Are you on mac?

1.) Change another USB cable

2.) try dfu-util -l to check if the device is listed

3.) Use another USB port

I am on Ubuntu 14.04

I managed to get the CC3000 flash to work.

sudo spark flash --usb cc3000

Now flashing yellow.

sudo spark flash --usb deep_update_2014_06

Now flashing green. Try to connect wifi via app.
No cores found.

That’s super weird. Usually the patch would solve it!

I guess the only way to get further is with hardcore JTAG stuff ?

I did get sent a JTAG shield, but I wouldnt know where to start.
I think you need some other gadget too though to connect it to the PC?

You will need a STlink v2 programmer but I don’t think it will help.

Try a factory reset followed by cc3000 patch then send in wifi credentials again. Check that they are correct just to be sure :wink:

Tried again - no dice. Thanks for your help - dont worry Ill put that in the pile of things to deal with later :smile:

1 Like